summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-02-08 13:41:30 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-02-08 13:41:30 +0700
commit242008019407ce4fbe6351e7a723cecb064f5a70 (patch)
treeafe6ddc83883765b69cfa17a6ea59593a0954100
parentdev-python/pygpgme: python3_9 added (diff)
downloadgentoo-24200801.tar.gz
gentoo-24200801.tar.bz2
gentoo-24200801.zip
net-misc/dropbox-cli: python3_9 added
Closes: https://bugs.gentoo.org/769206 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--net-misc/dropbox-cli/dropbox-cli-2020.03.04-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/dropbox-cli/dropbox-cli-2020.03.04-r1.ebuild b/net-misc/dropbox-cli/dropbox-cli-2020.03.04-r1.ebuild
new file mode 100644
index 000000000000..f0fa39d2b7d8
--- /dev/null
+++ b/net-misc/dropbox-cli/dropbox-cli-2020.03.04-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-r1 bash-completion-r1
+
+DESCRIPTION="Cli interface for dropbox (python), part of nautilus-dropbox"
+HOMEPAGE="https://www.dropbox.com/"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.py.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="net-misc/dropbox
+ ${PYTHON_DEPS}
+ dev-python/pygpgme[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin ${P}.py ${PN}
+ python_replicate_script "${D}"/usr/bin/${PN}
+ newbashcomp "${FILESDIR}"/${PN}-19-completion ${PN}
+}