summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-03-24 14:37:24 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-03-31 10:40:18 +0300
commit24363ddded3a1f659d63f38b44eae5d0e577bf1b (patch)
treead93eaea84b06ac769919a1f0cf95fec0560c3ac
parentwww-apps/gitea: drop old (security fix) (diff)
downloadgentoo-24363ddd.tar.gz
gentoo-24363ddd.tar.bz2
gentoo-24363ddd.zip
app-text/sigil: bump v1.5.1
Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-text/sigil/Manifest1
-rw-r--r--app-text/sigil/sigil-1.5.1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-text/sigil/Manifest b/app-text/sigil/Manifest
index 9072c688a525..e293799cebc8 100644
--- a/app-text/sigil/Manifest
+++ b/app-text/sigil/Manifest
@@ -1,2 +1,3 @@
DIST sigil-1.3.0.tar.gz 21697294 BLAKE2B 0ded5f2fa4a85a583113d268a0c287727faa9548a95ca3b564efac5db3528e0bf52b0df12f88cda46ae02851b0b85967c23c07cd3cd55073a87bcffbae8dec87 SHA512 fe1cbc2591dbfb54a2c561a3c53684447a4e90d944714bb182ee6ef160df74cc886c4d178d88d24a217643099ff9f409048ea2e5bb8ac88746fd280e48daa1b8
DIST sigil-1.4.3.tar.gz 24118565 BLAKE2B 4da0829cc82efe48c71c2a5d0be8477fd85291acd9578c14bd26f4521d2fd2322bec4c30002235254b9e731730a56b79787723059ba63884b75b33614cd94f39 SHA512 2f1e13a78a361df9b9031d5c04831d7e3ff09d16ed9cbd198b7735a4700f86e367f607554e805eb50db1a4562cbca33a8fb9cdf8167a95a43cbc2668ceb5550c
+DIST sigil-1.5.1.tar.gz 20020962 BLAKE2B ac70c117d69c4062d66151372fc8cbede48be6f38ceae7d1dd1bd49fd8a0a4a352c885a120e00ba729e64ebfa928103d07f7bb85d69cbb3385f640f4fcf42985 SHA512 281c8327f7a05b9c9f805b02ef4c21f50d340a2f9e09dcae74be30aad107b0f2605801f0239e9a503db70afa2b37b7931dfec0efa5662dde906ce6c014da8849
diff --git a/app-text/sigil/sigil-1.5.1.ebuild b/app-text/sigil/sigil-1.5.1.ebuild
new file mode 100644
index 000000000000..950ec134b837
--- /dev/null
+++ b/app-text/sigil/sigil-1.5.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="tk"
+
+inherit cmake python-single-r1 xdg-utils
+
+DESCRIPTION="Multi-platform WYSIWYG ebook editor for ePub format"
+HOMEPAGE="https://sigil-ebook.com/ https://github.com/Sigil-Ebook/Sigil"
+SRC_URI="https://github.com/Sigil-Ebook/Sigil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+plugins system-mathjax"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-text/hunspell:=
+ dev-libs/libpcre:3=[pcre16]
+ $(python_gen_cond_dep \
+ 'dev-python/css-parser[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]')
+ >=dev-qt/qtconcurrent-5.12:5
+ >=dev-qt/qtcore-5.12:5
+ >=dev-qt/qtgui-5.12:5
+ >=dev-qt/qtprintsupport-5.12:5
+ >=dev-qt/qtwebengine-5.12:5[widgets]
+ >=dev-qt/qtwidgets-5.12:5
+ sys-libs/zlib[minizip]
+ plugins? ( $(python_gen_cond_dep \
+ 'dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/dulwich[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]') )
+ system-mathjax? ( dev-libs/mathjax )
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/Sigil-${PV}"
+
+DOCS=( ChangeLog.txt README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_BUNDLED_DICTS=0
+ -DUSE_SYSTEM_LIBS=1
+ -DSYSTEM_LIBS_REQUIRED=1
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
+ -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ )
+ use system-mathjax && mycmakeargs+=( -DMATHJAX_DIR="${EPREFIX}"/usr/share/mathjax )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_fix_shebang "${ED}"/usr/share/sigil/
+ python_optimize "${ED}"/usr/share/sigil/
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}