summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-25 07:13:27 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-25 07:13:27 +0100
commit2441b0f173fbfc3be56423c9823d13ee3b1c49b6 (patch)
tree38c5669dea75be004bd55df58df3c80784e0df15
parentdev-ruby/slim: add ruby24 (diff)
downloadgentoo-2441b0f173fbfc3be56423c9823d13ee3b1c49b6.tar.gz
gentoo-2441b0f173fbfc3be56423c9823d13ee3b1c49b6.tar.bz2
gentoo-2441b0f173fbfc3be56423c9823d13ee3b1c49b6.zip
dev-ruby/haml: fix tests, add ruby24
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-ruby/haml/haml-4.0.7-r1.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-ruby/haml/haml-4.0.7-r1.ebuild b/dev-ruby/haml/haml-4.0.7-r1.ebuild
index 14564a4e5844..e57ebe24cda0 100644
--- a/dev-ruby/haml/haml-4.0.7-r1.ebuild
+++ b/dev-ruby/haml/haml-4.0.7-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby22 ruby23"
+USE_RUBY="ruby22 ruby23 ruby24"
RUBY_FAKEGEM_TASK_TEST="test"
RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
@@ -31,6 +31,7 @@ ruby_add_bdepend "
dev-ruby/minitest:5
dev-ruby/nokogiri
dev-ruby/rails:4.2
+ dev-ruby/bundler
)
doc? (
dev-ruby/yard
@@ -38,13 +39,9 @@ ruby_add_bdepend "
)"
all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' \
- -e 's/gem "minitest"/gem "minitest", "~>5.0"/'\
- -e '1igem "actionpack", "~>4.2"'\
- -e '1igem "activesupport", "~>4.2"'\
- -e '1igem "railties", "~>4.2"'\
- test/test_helper.rb || die
# Remove test that fails when RedCloth is available
sed -i -e "/should raise error when a Tilt filters dependencies are unavailable for extension/,+9 s/^/#/"\
test/filters_test.rb || die
+ # Avoid tests that are fragile for whitespace
+ sed -i -e '/test_\(text_area\|partials_should_not_cause_textareas\)/,/^ end/ s:^:#:' test/helper_test.rb || die
}