summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-10 07:53:22 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-10 08:32:39 +0100
commit24420cf8ec410a77b8fd5e92365ed5053dadc228 (patch)
tree1afa875fe14027eb62dc5399a1acd702cf50adc9
parentdev-python/elementpath: Bump to 2.4.0 (diff)
downloadgentoo-24420cf8.tar.gz
gentoo-24420cf8.tar.bz2
gentoo-24420cf8.zip
dev-python/imagesize: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/imagesize/Manifest1
-rw-r--r--dev-python/imagesize/imagesize-1.3.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/imagesize/Manifest b/dev-python/imagesize/Manifest
index 32af7afb8659..762c7b23f887 100644
--- a/dev-python/imagesize/Manifest
+++ b/dev-python/imagesize/Manifest
@@ -1 +1,2 @@
DIST imagesize-1.2.0.tar.gz 1274955 BLAKE2B 20293418635362f7360d2f02299f9392a96ca09773c97dd8eed38ca424008fa9d71139bbaf8d61e0daf5dbc90f3c46af9ee60d26e9fb1c2479eb8875ebcb7305 SHA512 c82a7fe433064c3a60ed664bad8ce4e602c527bcf2f7c9ab9be6ed650654626d9e0907028b2b0c5a484712bc989335b2b4f66494c8d445f5043ed4c2bc519700
+DIST imagesize-1.3.0.tar.gz 1279535 BLAKE2B 926b90ad493b790db41941467dd2dd0385f86064fc1ce9547670a52f925965effc9b8b7f61057158a4452cac2223b65dbfaecc34a19ddaf52067a9057560b56a SHA512 3686e513f03cc16f5237ca206cd1bf131eea968015ee4906f620ab1c8932ed24d19881807225a02fa319d0465da4b01851ec0bd0a47146ef914053185bc0c755
diff --git a/dev-python/imagesize/imagesize-1.3.0.ebuild b/dev-python/imagesize/imagesize-1.3.0.ebuild
new file mode 100644
index 000000000000..9781982b1a66
--- /dev/null
+++ b/dev-python/imagesize/imagesize-1.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pure Python module for getting image size from png/jpeg/jpeg2000/gif files"
+HOMEPAGE="https://github.com/shibukawa/imagesize_py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-solaris"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires Internet
+ test/test_get_filelike.py::test_get_filelike
+)