summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-21 23:33:08 +0000
committerSam James <sam@gentoo.org>2022-03-21 23:33:08 +0000
commit24631f38a61a53ffd2773090585eb98e9d4e8185 (patch)
tree5f082511c19452b07206c2feb4a8d037a9972c0e
parentsys-libs/glibc: fix WhitespaceFound (diff)
downloadgentoo-24631f38a61a53ffd2773090585eb98e9d4e8185.tar.gz
gentoo-24631f38a61a53ffd2773090585eb98e9d4e8185.tar.bz2
gentoo-24631f38a61a53ffd2773090585eb98e9d4e8185.zip
sys-apps/portage: disable USE=native-extensions for cross-compilation
It doesn't work because cross-compiling Python modules is either tricky or flat-out impossible, so let's disable it when cross-compiling to make life easier for people. Bug: https://bugs.gentoo.org/612158 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/portage/portage-3.0.30-r1.ebuild6
-rw-r--r--sys-apps/portage/portage-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/sys-apps/portage/portage-3.0.30-r1.ebuild b/sys-apps/portage/portage-3.0.30-r1.ebuild
index 590e0036a88a..87f2831cdf96 100644
--- a/sys-apps/portage/portage-3.0.30-r1.ebuild
+++ b/sys-apps/portage/portage-3.0.30-r1.ebuild
@@ -76,6 +76,10 @@ PDEPEND="
pkg_pretend() {
local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS ~UTS_NS"
+ if use native-extensions && tc-is-cross-compiler; then
+ einfo "Disabling USE=native-extensions for cross-compilation (bug #612158)"
+ fi
+
check_extra_config
}
@@ -99,7 +103,7 @@ python_prepare_all() {
>> cnf/make.globals || die
fi
- if use native-extensions; then
+ if use native-extensions && ! tc-is-cross-compiler; then
printf "[build_ext]\nportage_ext_modules=true\n" >> \
setup.cfg || die
fi
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index c741638d18e9..860091097621 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -76,6 +76,10 @@ PDEPEND="
pkg_pretend() {
local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS ~UTS_NS"
+ if use native-extensions && tc-is-cross-compiler; then
+ einfo "Disabling USE=native-extensions for cross-compilation (bug #612158)"
+ fi
+
check_extra_config
}
@@ -93,7 +97,7 @@ python_prepare_all() {
>> cnf/make.globals || die
fi
- if use native-extensions; then
+ if use native-extensions && ! tc-is-cross-compiler; then
printf "[build_ext]\nportage_ext_modules=true\n" >> \
setup.cfg || die
fi