summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-09-29 09:45:52 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-09-29 09:45:52 +0200
commit247352d1a2ec69e3818ae93e9a08fd8eacd1a268 (patch)
tree30bc13a5cc4ae8a08b473854c2147b83c355b0ce
parentdev-haskell/selective: Remove last-rited pkg (diff)
downloadgentoo-247352d1.tar.gz
gentoo-247352d1.tar.bz2
gentoo-247352d1.zip
dev-haskell/rsa: Remove last-rited pkg
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-haskell/rsa/Manifest1
-rw-r--r--dev-haskell/rsa/files/rsa-2.3.1-p1-ghc-8.8.patch19
-rw-r--r--dev-haskell/rsa/files/rsa-2.3.1-p2-ghc-8.8.patch21
-rw-r--r--dev-haskell/rsa/files/rsa-2.3.1-p3-ghc-8.8.patch23
-rw-r--r--dev-haskell/rsa/metadata.xml16
-rw-r--r--dev-haskell/rsa/rsa-2.3.1.ebuild49
-rw-r--r--profiles/package.mask1
7 files changed, 0 insertions, 130 deletions
diff --git a/dev-haskell/rsa/Manifest b/dev-haskell/rsa/Manifest
deleted file mode 100644
index 86a9aca3dad7..000000000000
--- a/dev-haskell/rsa/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST RSA-2.3.1.tar.gz 14705 BLAKE2B 065341bd3360410ca1e2ae1057b6b8112bc6cf1253ef12733d9d9564666b7c97e8088d35e0736a76768ebc8d40f497536ec0bb84565d849285666c591f1df3c6 SHA512 b4d3f406cd7b97237c2b36e2ba659f35871e02a6144b6cb48482fdc7999d9822758472c25b9eaef9ef6aeb8c503fa49b424350a543897217f3aec3084dd7572f
diff --git a/dev-haskell/rsa/files/rsa-2.3.1-p1-ghc-8.8.patch b/dev-haskell/rsa/files/rsa-2.3.1-p1-ghc-8.8.patch
deleted file mode 100644
index 2c985b3b5f62..000000000000
--- a/dev-haskell/rsa/files/rsa-2.3.1-p1-ghc-8.8.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-commit 8d867a693f91406f9b45e24d79a0637013c0e272
-Author: Ollie Charles <ollie@ocharles.org.uk>
-Date: Wed Sep 18 14:48:23 2019 +0100
-
- Update Pure.hs
-
-diff --git a/src/Codec/Crypto/RSA/Pure.hs b/src/Codec/Crypto/RSA/Pure.hs
-index 8e0f483..a69907d 100644
---- a/src/Codec/Crypto/RSA/Pure.hs
-+++ b/src/Codec/Crypto/RSA/Pure.hs
-@@ -111,7 +111,7 @@ instance Binary PrivateKey where
- d <- os2ip `fmap` getLazyByteString (fromIntegral (public_size pub))
- return (PrivateKey pub d 0 0 0 0 0)
-
--failOnError :: (Monad m, Show a) => Either a b -> m b
-+failOnError :: (MonadFail m, Show a) => Either a b -> m b
- failOnError (Left e) = fail (show e)
- failOnError (Right b) = return b
-
diff --git a/dev-haskell/rsa/files/rsa-2.3.1-p2-ghc-8.8.patch b/dev-haskell/rsa/files/rsa-2.3.1-p2-ghc-8.8.patch
deleted file mode 100644
index e2c7348eb38c..000000000000
--- a/dev-haskell/rsa/files/rsa-2.3.1-p2-ghc-8.8.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-commit d621ae1603f27b3de867b46e5ad4d28460097dac
-Author: Ollie Charles <ollie@ocharles.org.uk>
-Date: Wed Sep 18 14:52:34 2019 +0100
-
- Update Pure.hs
-
-diff --git a/src/Codec/Crypto/RSA/Pure.hs b/src/Codec/Crypto/RSA/Pure.hs
-index a69907d..e3513a9 100644
---- a/src/Codec/Crypto/RSA/Pure.hs
-+++ b/src/Codec/Crypto/RSA/Pure.hs
-@@ -111,8 +111,8 @@ instance Binary PrivateKey where
- d <- os2ip `fmap` getLazyByteString (fromIntegral (public_size pub))
- return (PrivateKey pub d 0 0 0 0 0)
-
--failOnError :: (MonadFail m, Show a) => Either a b -> m b
--failOnError (Left e) = fail (show e)
-+failOnError :: (Monad m, Show a) => Either a b -> m b
-+failOnError (Left e) = error (show e)
- failOnError (Right b) = return b
-
- -- ----------------------------------------------------------------------------
diff --git a/dev-haskell/rsa/files/rsa-2.3.1-p3-ghc-8.8.patch b/dev-haskell/rsa/files/rsa-2.3.1-p3-ghc-8.8.patch
deleted file mode 100644
index 6aebe6fab6ce..000000000000
--- a/dev-haskell/rsa/files/rsa-2.3.1-p3-ghc-8.8.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-commit bb712862c868975ab033e1079751d9e3787d3a33
-Author: Ollie Charles <ollie@ocharles.org.uk>
-Date: Wed Sep 18 14:54:22 2019 +0100
-
- Update Test.hs
-
-diff --git a/Test.hs b/Test.hs
-index dd61302..4fa26ca 100644
---- a/Test.hs
-+++ b/Test.hs
-@@ -98,10 +98,10 @@ instance Arbitrary LargePrime where
- arbitrary =
- do seed <- BSS.pack `fmap` replicateM 4096 arbitrary
- case newGen seed of
-- Left _ -> fail "DRBG initialization error."
-+ Left _ -> error "DRBG initialization error."
- Right (g :: HashDRBG) ->
- case largeRandomPrime g 64 of
-- Left _ -> fail "Large prime generation failure."
-+ Left _ -> error "Large prime generation failure."
- Right (i, _) -> return (LP i)
-
- data KeyPairIdx = KPI Int
diff --git a/dev-haskell/rsa/metadata.xml b/dev-haskell/rsa/metadata.xml
deleted file mode 100644
index 89642b8bdd30..000000000000
--- a/dev-haskell/rsa/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- This library implements the RSA encryption and signature
- algorithms for arbitrarily-sized ByteStrings. While the
- implementations work, they are not necessarily the fastest ones
- on the planet. Particularly key generation. The algorithms
- included are based of RFC 3447, or the Public-Key Cryptography
- Standard for RSA, version 2.1 (a.k.a, PKCS#1 v2.1).
- </longdescription>
-</pkgmetadata>
diff --git a/dev-haskell/rsa/rsa-2.3.1.ebuild b/dev-haskell/rsa/rsa-2.3.1.ebuild
deleted file mode 100644
index f0a8153fa08a..000000000000
--- a/dev-haskell/rsa/rsa-2.3.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.9999
-#hackport: flags: -oldbase,-buildtestexecutable
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-MY_PN="RSA"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Implementation of RSA, using the padding schemes of PKCS#1 v2.1"
-HOMEPAGE="https://hackage.haskell.org/package/RSA"
-SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/crypto-api-0.10:=[profile?] <dev-haskell/crypto-api-0.14:=[profile?]
- >=dev-haskell/crypto-pubkey-types-0.2:=[profile?] <dev-haskell/crypto-pubkey-types-0.6:=[profile?]
- >=dev-haskell/sha-1.6.4.1:=[profile?] <dev-haskell/sha-2.0:=[profile?]
- >=dev-lang/ghc-7.8.2:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
- test? ( >=dev-haskell/crypto-pubkey-types-0.4 <dev-haskell/crypto-pubkey-types-0.6
- >=dev-haskell/drbg-0.5.2 <dev-haskell/drbg-0.7
- >=dev-haskell/quickcheck-2.5 <dev-haskell/quickcheck-3
- >=dev-haskell/tagged-0.2 <dev-haskell/tagged-0.9
- >=dev-haskell/test-framework-0.8.0.3 <dev-haskell/test-framework-0.10
- >=dev-haskell/test-framework-quickcheck2-0.3.0.2 <dev-haskell/test-framework-quickcheck2-0.5 )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=("${FILESDIR}"/${P}-p1-ghc-8.8.patch
- "${FILESDIR}"/${P}-p2-ghc-8.8.patch
- "${FILESDIR}"/${P}-p3-ghc-8.8.patch)
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-buildtestexecutable \
- --flag=-oldbase
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 09b24daa613c..3601e4b66b9e 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -339,7 +339,6 @@ dev-haskell/rerebase
dev-haskell/rfc5051
dev-haskell/rio-orphans
dev-haskell/rio-prettyprint
-dev-haskell/rsa
# hololeap <hololeap@protonmail.com> (2022-08-21)
# doctest-parallel does not currently work with Setup.hs (used internally by