summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-27 19:47:05 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-27 19:59:45 +0100
commit247cf30944d89ef9083c42153890db8d5a89fb4c (patch)
tree6e690d995a1b21cedec9bff5b737f8a9e8d52b45
parentapp-emacs/async: bump to 1.9.8 (diff)
downloadgentoo-247cf30944d89ef9083c42153890db8d5a89fb4c.tar.gz
gentoo-247cf30944d89ef9083c42153890db8d5a89fb4c.tar.bz2
gentoo-247cf30944d89ef9083c42153890db8d5a89fb4c.zip
app-emacs/kind-icon: bump to 0.2.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/kind-icon/Manifest1
-rw-r--r--app-emacs/kind-icon/kind-icon-0.2.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/kind-icon/Manifest b/app-emacs/kind-icon/Manifest
index 6dd04d602270..1ba74d9e0b2d 100644
--- a/app-emacs/kind-icon/Manifest
+++ b/app-emacs/kind-icon/Manifest
@@ -1 +1,2 @@
DIST kind-icon-0.2.0.tar.xz 19804 BLAKE2B 6efd4470114adf451bd08a7158b0e9c6fa5d51978d0228997983d3164d0e4451dbb0ea413bcf64967a18a08e78a76ac59de4acd61a2304512920a37cd9c187f8 SHA512 fafe8eccd2ad7f459105357b6a097cdcdb2e4e3e1567acb3bdaa4fa9e861fcbf44ac5b697ff8755d0c9789e4575de6e6504f86bb851283e89d0571c3b5b65e0a
+DIST kind-icon-0.2.1.tar.gz 21869 BLAKE2B 788dad3e334bb2f85dbd260eb04b60970dcea1030d920f922bc1b00fc561fe825e959891af73af391efa4f3408d72bbd5f021fa3a52edaf27ebdb8894c76a708 SHA512 9ebea8c1bca4b85f1486b0114df06b29463d3852ebaf66a8cf221a73c5456444ba0e1c6d4e43ddac8f51ea2cece18edc2208ab341a8124c5f71a06141f8f641e
diff --git a/app-emacs/kind-icon/kind-icon-0.2.1.ebuild b/app-emacs/kind-icon/kind-icon-0.2.1.ebuild
new file mode 100644
index 000000000000..be600aa4026c
--- /dev/null
+++ b/app-emacs/kind-icon/kind-icon-0.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+
+inherit elisp
+
+DESCRIPTION="Completion kind icons"
+HOMEPAGE="https://github.com/jdtsmith/kind-icon/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/jdtsmith/${PN}.git"
+else
+ SRC_URI="https://github.com/jdtsmith/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/svg-lib
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-make-autoload-file
+ elisp_src_compile
+}