summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-22 08:06:17 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-22 09:40:43 +0100
commit2492f18b1808488f48d6b4714fd7f32f8fb7dbfd (patch)
tree9627228441e1eed2d6be4afc2faa57e64cfde172
parentdev-libs/libpcre2: Removed old (diff)
downloadgentoo-2492f18b1808488f48d6b4714fd7f32f8fb7dbfd.tar.gz
gentoo-2492f18b1808488f48d6b4714fd7f32f8fb7dbfd.tar.bz2
gentoo-2492f18b1808488f48d6b4714fd7f32f8fb7dbfd.zip
dev-python/hypothesis: Bump to 4.46.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-4.46.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 0e25bcb3b9c8..a1e12bc53564 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-python-3.74.3.tar.gz 552616 BLAKE2B e19a0991e7ae2fa6208c81d336cc
DIST hypothesis-python-4.15.0.tar.gz 1175925 BLAKE2B f3e3888b3f4e542d567bdaad2582eb23bd8ab2e218f1bde82ba1639123f32e8c147313c22b15781d8986574813b5f6eb7c23ce28367e86bb304d33a23f179fa0 SHA512 7d9788b351196fc20e66e210b7d60b4ddb1507b85cf5a29de228600e07f676ccd1352f5d2ab0820b3c8c1a1e8ff145225f00a25aec5f325cc7405ffd0dfcd9f7
DIST hypothesis-python-4.44.2.tar.gz 3240386 BLAKE2B 3fe3295ba1f7401e1fb74af894d91eda525f8ef51eb893f1f8e5224cead8572f3c06f6a4bb345c123e56ed06d0676c85dc4477a80e54480baa6bd9f5f2bc069e SHA512 bebc5da337fa74a75d08cb57531c2f6b8ba1ab16d1a3d9be8348cd56ada1ab25a34e3b812a4aa71bf172bc97ebc8df0accdad37466f9162c3f8f2a8edbea9da9
DIST hypothesis-python-4.45.1.tar.gz 3252805 BLAKE2B ec319d9432ebf723668e14e5f7a07f5aee0736e477eb102f79a528537aae1e2bcca1dfb6e12117026b1976f25cb720f5a0ed389f0c942715eab8470ec8aa0833 SHA512 6da73332c7e48ea9608732117633f6c3960c944ce03a5f67ecb72d2fad2ccb035ea3116762f9512f53735489d87e90a32631b01ee3ab679c8ca65bdebd47c785
+DIST hypothesis-python-4.46.0.tar.gz 3253156 BLAKE2B 5e73fdb756aa2fa0b10342d11addeed6a0b258f24ae1ee5fa231fae7ad98d1fcaa792713fc70f05f49408363c29e03571f1aa3b7e7d0810fcb436af53ef9f2ce SHA512 5d3bc696c35e189f594dc69eaa74af7b51710dac46aad48c8978ef8425c0b614aabae03e62e4fdf5dcb98d0284b56ccc1ca7af87c6eee763e686ab84c19b82ec
diff --git a/dev-python/hypothesis/hypothesis-4.46.0.ebuild b/dev-python/hypothesis/hypothesis-4.46.0.ebuild
new file mode 100644
index 000000000000..3def9e851218
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-4.46.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local pyver=$(python_is_python3 && echo 3 || echo 2)
+ pytest -vv tests/cover tests/pytest tests/py${pyver} ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}