summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-16 20:13:34 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-16 20:22:18 +0100
commit24b8ae0cdeda9b790495acbfe5c21ca665968746 (patch)
tree4ae39125653d33910b364ccaf345bdf70dbbd238
parentgames-board/tetzle: add 2.2.3 (diff)
downloadgentoo-24b8ae0cdeda9b790495acbfe5c21ca665968746.tar.gz
gentoo-24b8ae0cdeda9b790495acbfe5c21ca665968746.tar.bz2
gentoo-24b8ae0cdeda9b790495acbfe5c21ca665968746.zip
dev-python/jupyter-server: Bump to 2.12.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyter-server/Manifest1
-rw-r--r--dev-python/jupyter-server/jupyter-server-2.12.5.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/jupyter-server/Manifest b/dev-python/jupyter-server/Manifest
index ae46ccaa3077..0b38a519e5a5 100644
--- a/dev-python/jupyter-server/Manifest
+++ b/dev-python/jupyter-server/Manifest
@@ -2,4 +2,5 @@ DIST jupyter_server-2.12.1.tar.gz 713271 BLAKE2B 4f65b1ed51dfa69921455a46a2a1e49
DIST jupyter_server-2.12.2.tar.gz 713700 BLAKE2B 37739ff282a40a1d49c8abe99987497a90803fe48205451ab1ccf731f4e694bbe70157d1444de34ff4f0bc1280a021e3b857c9968615e59964336d8fca8d973d SHA512 c43052bff91d245b942c0eec5cf435b1b2266f5a304844c2fe3bcf1dcef80cc91178b2789cc0634cafeab8cb67083a232bd1f433acb69cffd2c3026a56a264f1
DIST jupyter_server-2.12.3.tar.gz 713798 BLAKE2B f0bab746557247b20ea9b34c72b43d101dfacc4ab7799e76732a63b5d6088d2d523a52dbfc7324aeb7105de6804ceccd3d4c32f0dfadd8ba5ac18b60eabf9c3c SHA512 8c30cc86b6fcc8eb91174be55b0dee7733b8f446b2c5ccf17f3369f628cf059b33e534fe3b943e8697894ef90124c52973fd010bb005c65064c525699e8c1c43
DIST jupyter_server-2.12.4.tar.gz 713846 BLAKE2B f802474367b70663576c1fff87818db8559ce602ae5793aed3f85e720e0a5542d6cae2369726616d3e5a8233aa154b327432050ff99127c499608e36ed69bd07 SHA512 25c6d79342b4905c75465c0ce4a1e44b8fbdb1ff2d4f665739fac02e0bad31b5b0912d006f0cf530dded25bd93a816dc4e340d91bf2f2c0b846d0960a5d4a3ce
+DIST jupyter_server-2.12.5.tar.gz 713833 BLAKE2B f6e133a5f778d2abe9971a94db9c033fbfba587fc6265dbeed20f903cb1f1007b53f263c5674945e324dd15879e77ffab03f94c236d4ddbde00179af7ae71f94 SHA512 dd4fee86cfe82641dc9bbab2de93f65b45e78d56fad6d0a5ecdc442a4facc93aecbe90516200fa742f13d83039119640279efd4c42ff53a08786671c79d4a268
DIST jupyter_server-2.9.1.tar.gz 709013 BLAKE2B dee0de771bb8488cccaecb49e2b4a2003f2530243013cafa7f170384380423a7c190504baabf458c59ffece28c4f60662c0530f55535dae25699be269f159743 SHA512 148c3eaa4b6ca1147961c1188e0016a634e5adae350e762903bdde000acde7ab62507e71dbe1278c2b9358ce2cf1c28c17ea8b184f3d4a2d59277910b5b44965
diff --git a/dev-python/jupyter-server/jupyter-server-2.12.5.ebuild b/dev-python/jupyter-server/jupyter-server-2.12.5.ebuild
new file mode 100644
index 000000000000..47b4d4c54c22
--- /dev/null
+++ b/dev-python/jupyter-server/jupyter-server-2.12.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core services, APIs, and REST endpoints to Jupyter web applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_server/
+ https://pypi.org/project/jupyter-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/anyio-3.1.0[${PYTHON_USEDEP}]
+ dev-python/argon2-cffi[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-7.4.4[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
+ dev-python/jupyter-server-terminals[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-events-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-6.4.4[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3.0[${PYTHON_USEDEP}]
+ dev-python/overrides[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/prometheus-client[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-24[${PYTHON_USEDEP}]
+ >=dev-python/send2trash-1.8.2[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.6.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+
+"
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # This fails if your terminal is zsh (and maybe other non-bash as well?)
+ tests/test_terminal.py
+ # Fails because above is ignored
+ tests/auth/test_authorizer.py
+ # Fails with additional extensions installed
+ tests/extension/test_app.py::test_stop_extension
+ )
+
+ # FIXME: tests seem to be affected by previously installed version
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest \
+ -p pytest_tornasync.plugin \
+ -p jupyter_server.pytest_plugin \
+ -p pytest_console_scripts \
+ -p pytest_timeout \
+ -o tmp_path_retention_policy=all
+}