summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-02 13:44:52 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-02 13:45:56 +0200
commit24bafb1a69e2bdac6df6afe5fc3bbee97729d550 (patch)
tree19775e263936ae96bbb3f7aad5eec2dc9de9ddc1
parentdev-ada/gnatcoll: Add use flag gnat_* to 2017 version (diff)
downloadgentoo-24bafb1a.tar.gz
gentoo-24bafb1a.tar.bz2
gentoo-24bafb1a.zip
net-libs/nghttp2: Bump to version 1.24.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.24.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 54ceece1f533..f770a4b57a5e 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -3,3 +3,4 @@ DIST nghttp2-1.19.0.tar.gz 2159530 SHA256 b67946ad211aa3f7c91f4d866f47b056e821da
DIST nghttp2-1.22.0.tar.gz 2176030 SHA256 f4b5f3afdad69ea2b2542bc998128e2d02a33c40e53e60fd814788518b56b13f SHA512 e439e4b2b06a8bfef80d1d963d70612b13eaf613e2be78537971e867fd82f222e5457533dee540c5239e00ee78ca8c1efbaccf8cdeacd1c46b58f89ee5ecf327 WHIRLPOOL 4d493e5ef129432ce17110279178dda9d0cf1aaa4df82a05084ae052d3fe21342aadcac46fb9c52434f6e3325c99d2750b57a47d7c11292eda2b09f15669d927
DIST nghttp2-1.23.0.tar.gz 2178667 SHA256 90627fb05a7047f86a7e2c360b3d3d564119a589928ff741201ed1a65316a84b SHA512 6e43d525af5af0389e44bf4b6f4f18fbfe85e5a7f679859e45cc04de1fe6defddc1cb241aa127b1e6a40efb79f471e42f68c1052edac9c19991af294d3e69dc7 WHIRLPOOL c404d1aa4b6858b046e75ff438f2c1caf2de49e6609d1e05accb50cb89281c877024bb3198bdbe7f92daac4af703f6102f12b17554868de992ee58e0f11a17fc
DIST nghttp2-1.23.1.tar.gz 2175088 SHA256 ff8eb39a3e19b438c38ec99fcf783fba4f9cb2484c6a7207b42b356210c5e41a SHA512 eb709f0174b6f2030d52f76e386e1240a1708bf948c0437eda0a6ea1bc828af3dfaaaf951629043edbd986f8ba2de6b6f838cb56523028494037e36b968ad39f WHIRLPOOL 73b368e2d67f3879b166a56ece4484a4a46f328b53099d90a89e3dd38d8bc43c716ef8f9aa120490615575876380d34080db066194e5a5f93a95f50ff1db2dd4
+DIST nghttp2-1.24.0.tar.gz 2177551 SHA256 5058da99c94764ff39f4a7046b9c8f0b6bafa10ec2fc096945a5d9d693654840 SHA512 e69a286c0dbd15073f19b908995021c78a25c94f1d435c1ddc5f7277d346d6cc57d2c826588076e269bf700980c7f355f2e0d45f08f0bbb768f7d78e7f543671 WHIRLPOOL 0915a0789aa0d147131bfa0ad40db90030819f40bff5c28d3a5ce07da9eca8ec8fa453747ef99b66bc20957b446b41cd3861e4db588e4d0251d348d6c8b71f10
diff --git a/net-libs/nghttp2/nghttp2-1.24.0.ebuild b/net-libs/nghttp2/nghttp2-1.24.0.ebuild
new file mode 100644
index 000000000000..3ec4b994bb7c
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.24.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}