summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-01-15 00:01:06 +0100
committerSebastian Pipping <sping@gentoo.org>2023-01-18 00:26:55 +0100
commit24c6a0ce8d0364a419b93ecb72c44199c1296e5b (patch)
tree5619dbd43772074048ef028dfa012dcca2aac3fc
parentdev-vcs/git: Stabilize 2.39.1 amd64, #891233 (diff)
downloadgentoo-24c6a0ce8d0.tar.gz
gentoo-24c6a0ce8d0.tar.bz2
gentoo-24c6a0ce8d0.zip
www-client/httrack: 3.49.4
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
-rw-r--r--www-client/httrack/Manifest2
-rw-r--r--www-client/httrack/httrack-3.49.4.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/www-client/httrack/Manifest b/www-client/httrack/Manifest
index fdce299d8943..11e281aac811 100644
--- a/www-client/httrack/Manifest
+++ b/www-client/httrack/Manifest
@@ -1 +1,3 @@
+DIST coucal-73ada075553b7607d083037a87cb9c73b3683bfc.gh.tar.gz 21306 BLAKE2B c04b369f6011aa14169a933ba2a39dcc114d056968a2dc51a752979c59e93332bc302f53e865b78c7324fd568fdc3666eebe60a887fb8417e8ee7a1fbe5ed0f6 SHA512 818cfdbf6038cf27433973d3994f7231c61c366b44a28dd74e1a6d216c9bbb66b0699bf40ccbd7816de7876d73b096b93d895f6f61efbd0d79c39d559b3aee73
DIST httrack-3.49.2.tar.gz 1835116 BLAKE2B 4073b70268bcea8acf0a9ac10deed14764ccd405c82f1b9f48dc74d3dbef130161234b59e70e72305a195d21155474831e8359eea9b96d275481a69b1c1ff561 SHA512 84a13a776b278533f7f0635ebd764387c3399b01c0644d8af9b46fc8112dc3c6e568c17969d4f6c2db32b5474344c39f86cf51957c09eb807ebe305a554ba5c8
+DIST httrack-3.49.4.gh.tar.gz 1761838 BLAKE2B 5fcfb3dcf97bb672dd7a93a61c0eee3d3d18615abd547932c77b46f930ae30d8395df61614c0ccb4cd42552546f6a81323e9048afc17eecfd2136da4199c6158 SHA512 7cc25af0cf493f3304e15e021769646ca035c54145eb9fdc0b383cfe05d369ae50ffd222cbbe23de3d8270947ff3a564ab59e7f7f5186d63e8e63d56fae1e10d
diff --git a/www-client/httrack/httrack-3.49.4.ebuild b/www-client/httrack/httrack-3.49.4.ebuild
new file mode 100644
index 000000000000..2f90be8e6eb5
--- /dev/null
+++ b/www-client/httrack/httrack-3.49.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit autotools xdg-utils
+
+# TODO unbundle coucal, upstream ticket https://github.com/xroche/httrack/issues/247
+COUCAL_COMMIT=73ada075553b7607d083037a87cb9c73b3683bfc
+DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
+HOMEPAGE="https://www.httrack.com/"
+SRC_URI="https://github.com/xroche/httrack/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://github.com/xroche/coucal/archive/${COUCAL_COMMIT}.tar.gz -> coucal-${COUCAL_COMMIT}.gh.tar.gz"
+
+COUCAL_LICENSE="BSD public-domain"
+LICENSE="GPL-3 ${COUCAL_LICENSE}"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND=">=sys-libs/zlib-1.2.5.1-r1
+ >=dev-libs/openssl-1.1.0:=
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README greetings.txt history.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.48.13-minizip.patch
+)
+
+src_prepare() {
+ rmdir "${S}"/src/coucal || die
+ mv "${WORKDIR}"/coucal-${COUCAL_COMMIT} "${S}"/src/coucal || die
+
+ default
+
+ # We need to patch use of /usr/lib because it is a problem with
+ # linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/732272).
+ # The grep sandwich acts as a regression test so that a future
+ # version bump cannot break patching without noticing.
+ if [[ "$(get_libdir)" != lib ]]; then
+ grep -wq '{ZLIB_HOME}/lib' m4/check_zlib.m4 || die
+ sed "s,{ZLIB_HOME}/lib,{ZLIB_HOME}/$(get_libdir)," -i m4/check_zlib.m4 || die
+ grep -w '{ZLIB_HOME}/lib' m4/check_zlib.m4 && die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Make webhttrack work despite FEATURES=nodoc cutting
+ # all of /usr/share/doc/ away (bug #493376)
+ if has nodoc ${FEATURES} ; then
+ dodir /usr/share/${PF}/
+ mv "${D}"/usr/share/{doc/,}${PF}/html || die
+
+ rm "${D}"/usr/share/${PN}/html || die
+ dosym ../../${PF}/html /usr/share/${PN}/html
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}