summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-09-08 07:29:05 +1200
committerKent Fredric <kentnl@gentoo.org>2018-09-08 07:31:01 +1200
commit24c80c90da487a546906752c9b63596fc6645a57 (patch)
tree0307919d66f4487c08dce3a000f99ecdab382f49
parentnet-wireless/wireless-regdb: bump (diff)
downloadgentoo-24c80c90da487a546906752c9b63596fc6645a57.tar.gz
gentoo-24c80c90da487a546906752c9b63596fc6645a57.tar.bz2
gentoo-24c80c90da487a546906752c9b63596fc6645a57.zip
dev-perl/Authen-Radius: Bump to version 0.270.0
- export contrib/ via USE=examples Upstream: - Force FreeRADIUS dictionary format when BEGIN-VENDOR directive is found - Load included files using requested format - Add full support for octets type Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-perl/Authen-Radius/Authen-Radius-0.270.0.ebuild49
-rw-r--r--dev-perl/Authen-Radius/Manifest1
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/Authen-Radius/Authen-Radius-0.270.0.ebuild b/dev-perl/Authen-Radius/Authen-Radius-0.270.0.ebuild
new file mode 100644
index 000000000000..e8f19084fc27
--- /dev/null
+++ b/dev-perl/Authen-Radius/Authen-Radius-0.270.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PORTAONE
+DIST_VERSION=0.27
+DIST_EXAMPLES=("contrib/*")
+inherit perl-module
+
+DESCRIPTION="Communicate with a Radius server from Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Data-Dumper-1.0.0
+ >=dev-perl/Data-HexDump-0.20.0
+ >=virtual/perl-Digest-MD5-2.200.0
+ >=virtual/perl-IO-1.120.0
+ >=dev-perl/Net-IP-1.260.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ dev-perl/Test-NoWarnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.26-cisco-dictionary.patch
+ "${FILESDIR}"/${PN}-0.26-no-install-db.patch
+)
+
+src_configure() {
+ export OPTIMIZE="$CFLAGS"
+ perl-module_src_configure
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Really want to install these radius dictionaries?
+ insinto /etc/raddb
+ doins raddb/dictionary*
+}
diff --git a/dev-perl/Authen-Radius/Manifest b/dev-perl/Authen-Radius/Manifest
index 447e3579de1d..e60cf7afab44 100644
--- a/dev-perl/Authen-Radius/Manifest
+++ b/dev-perl/Authen-Radius/Manifest
@@ -1 +1,2 @@
DIST Authen-Radius-0.26.tar.gz 49432 BLAKE2B 05ce64cf463faa1ad1004a659859961d6df24d0651a180603a5a5fc3d672a91f8df521f7d19bbc7b62aa0d63e1ae5b54dec3d46718973ee160f3e7bae5f15d02 SHA512 6779712cd4fdc45115c6e68766ef58c8b1dc9bf3037f3e0e243bc23318d13b09104df5f825b40ce26f7eebe52e6c4887efc8525334f2ab00da23fe76322f0b56
+DIST Authen-Radius-0.27.tar.gz 49679 BLAKE2B 81a676cce378054b971932f78b37c6e9683b2acd0f214ad4dbdb84e089b683e6011cc3f75e952d687a364d29c1907b586f369fe6e5e9d1cf77ce131b8ce9035d SHA512 0b039b3b5b434225a92596075a3943f278f87c634c6764de477a31de515065d1ded762b38621c338785f73fe2a0e132d835a33a00891707950777a16e0277f67