summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-05 02:26:48 +0000
committerSam James <sam@gentoo.org>2021-11-05 02:28:19 +0000
commit24ca452f3ebb5b0e05cf5159137c272a554bff99 (patch)
tree77d83754e4556cb75138f2c481db01c19c518163
parentdev-libs/libretls: Stabilize 3.3.4 sparc, #821838 (diff)
downloadgentoo-24ca452f.tar.gz
gentoo-24ca452f.tar.bz2
gentoo-24ca452f.zip
dev-python/scipy: skip known-failing longstanding test failure
Known broken upstream for years (ditto in Gentoo). Other tests seem okay and we're going to have to hope that's sufficient until there's a resolution upstream. Other distros are trying to battle this too. Bug: https://bugs.gentoo.org/743295 Bug: https://github.com/scipy/scipy/issues/9245 Bug: https://github.com/scipy/scipy/issues/12401 Bug: https://github.com/scipy/scipy/issues/12471 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/scipy/scipy-1.7.1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/scipy/scipy-1.7.1.ebuild b/dev-python/scipy/scipy-1.7.1.ebuild
index d2dc22464cf4..b972b9258178 100644
--- a/dev-python/scipy/scipy-1.7.1.ebuild
+++ b/dev-python/scipy/scipy-1.7.1.ebuild
@@ -106,6 +106,11 @@ python_prepare_all() {
sed -e "s:== 'levy_stable':in ('levy_stable', 'crystalball', 'ncf'):" \
-i scipy/stats/tests/test_continuous_basic.py || die
+ # Skip known-failing test. Broken on all versions in Gentoo for years.
+ # bug #743295
+ sed -e 's:test_bisplev_integer_overflow:_&:' \
+ -i scipy/interpolate/tests/test_fitpack.py || die
+
if has_version ">=sci-libs/lapack-3.10"; then
sed -e 's:test_sort(:_&:' \
-i scipy/linalg/tests/test_decomp.py || die