summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2019-01-26 11:27:34 -0600
committerWilliam Hubbs <williamh@gentoo.org>2019-01-26 11:40:59 -0600
commit24e6563f676d1774b76f15bb3572b952ed2ebf7c (patch)
tree5b0825af36108c2bb18741303f30044b5600105a
parentdev-util/cmocka: stable 1.1.3 for ppc64, bug #676198 (diff)
downloadgentoo-24e6563f.tar.gz
gentoo-24e6563f.tar.bz2
gentoo-24e6563f.zip
dev-util/meson: 0.49.1 bump
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--dev-util/meson/Manifest1
-rw-r--r--dev-util/meson/meson-0.49.1.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-util/meson/Manifest b/dev-util/meson/Manifest
index 39b14059bd13..36ecd30f9102 100644
--- a/dev-util/meson/Manifest
+++ b/dev-util/meson/Manifest
@@ -4,3 +4,4 @@ DIST meson-0.48.0.tar.gz 1307251 BLAKE2B cafae408a219a8f31b756cae28178480eeadac8
DIST meson-0.48.1.tar.gz 1310408 BLAKE2B e90c5c0b396883ac516eb3a5de04a1caff084a7f018e3f9b7565ec91e520bf4c0e05a72855b3b35e361623c6bf792e471846a7bac13fabd8b42c5256af017703 SHA512 248856cbab0aba959a01a9759261108baf93eef92d454b9ebb7f54edf1aa3e26f6050e389c9889ca23b19321d835617bacd361fc598b7185f6485bc6a403534c
DIST meson-0.48.2.tar.gz 1311011 BLAKE2B 54cb8ca4164238f1c2b77327c330a7615a8d62c63c0cbedcdbe395bf2a99c454407fbc61af8d61d38a85de5dee18e73b98b534a2c9d19cc8f622e25549b84bbf SHA512 beebc90df420c15255c49a13e2f4917934fec8fb2c5b878a59ee0cd2ae46eb05571e995e12b3110b72be89fd11ab4c534ed72aa6d6fe72719ef060df5e75695f
DIST meson-0.49.0.tar.gz 1338576 BLAKE2B 6ae3152af337591928232c5dea8331185c8aa7f712019ed3635269544e4506fc0d9195d3d59128c5e5a286aff8ad1e3a0edf3afe28ab469989753c3c988ddae3 SHA512 6aba2a1c1dbf247fc30526215dd499b7c918c19f7f16a7216f5762e95cde39b7cfae2a1ebca1e2ea5323f2f855ed98c99af1b9048aa00bd1ffbe8da20ef2121b
+DIST meson-0.49.1.tar.gz 1340585 BLAKE2B 7df52f68948c74d4d713d57406a7b496e33740e43ea069b5cb6474a80b94800f8af7983413f3154eb2e6b7f0ea8df51e7359b8b7c6661f454dbb9a21ccf9bdc6 SHA512 cc955509d2c82b12d347f7a670a0e2abf5f6a4455dda3d53ec4abb0930b5f1c4a0ff996223ba5a5333bfec66e5d3fb3448a8187d4640e4b65397fc3e0e43dc72
diff --git a/dev-util/meson/meson-0.49.1.ebuild b/dev-util/meson/meson-0.49.1.ebuild
new file mode 100644
index 000000000000..6149ebc1ee51
--- /dev/null
+++ b/dev-util/meson/meson-0.49.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mesonbuild/meson"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+fi
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Open source build system"
+HOMEPAGE="http://mesonbuild.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ dev-util/ninja
+ dev-vcs/git
+ virtual/pkgconfig
+ )
+"
+
+python_prepare_all() {
+ # ASAN and sandbox both want control over LD_PRELOAD
+ # https://bugs.gentoo.org/673016
+ sed -i -e 's/test_generate_gir_with_address_sanitizer/_&/' run_unittests.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ if tc-is-gcc; then
+ # LTO fails for static libs because the bfd plugin in missing.
+ # Remove this workaround after sys-devel/gcc-config-2.0 is stable.
+ # https://bugs.gentoo.org/672706
+ tc-getPROG AR gcc-ar >/dev/null
+ fi
+ distutils-r1_src_test
+}
+
+python_test() {
+ (
+ # test_meson_installed
+ unset PYTHONDONTWRITEBYTECODE
+
+ # test_cross_file_system_paths
+ unset XDG_DATA_HOME
+
+ ${EPYTHON} -u run_tests.py
+ ) || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/vim/vimfiles
+ doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
+ insinto /usr/share/zsh/site-functions
+ doins data/shell-completions/zsh/_meson
+}