summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-02-24 14:09:57 -0500
committerMatt Turner <mattst88@gentoo.org>2024-02-24 15:15:25 -0500
commit24e83c703e9f87df220546750b20f3075bd0397c (patch)
tree6b17852c06bd2f47a788401a33dd3e93528224c4
parentdev-libs/libwacom: Version bump to 2.10.0 (diff)
downloadgentoo-24e83c703e9f87df220546750b20f3075bd0397c.tar.gz
gentoo-24e83c703e9f87df220546750b20f3075bd0397c.tar.bz2
gentoo-24e83c703e9f87df220546750b20f3075bd0397c.zip
net-libs/libproxy: Version bump to 0.5.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-libs/libproxy/Manifest1
-rw-r--r--net-libs/libproxy/libproxy-0.5.4.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-libs/libproxy/Manifest b/net-libs/libproxy/Manifest
index b51521aacb35..7634549b162f 100644
--- a/net-libs/libproxy/Manifest
+++ b/net-libs/libproxy/Manifest
@@ -1 +1,2 @@
DIST libproxy-0.5.3.tar.gz 60069 BLAKE2B adfa982344470251667b113f12f77722f6793ceeec902ccf82e32e80e15836384fbe1ccbec8865fc877fa04b25e6985847eef75b4ce437dbf0410d16e2bd5f36 SHA512 0fa4c677372afa76a9f143abb1472af1df85e1190425ec4168b98e575a9b9c9fe3dcc56062609da8ef266d56dfb153e7f7a1c15aed2d385003d9f3f421d08590
+DIST libproxy-0.5.4.tar.gz 60605 BLAKE2B b603781d454ae9d177522d85027f763275e6f243579e8dd808fc5f740438105ac9f782bd35c39cb0007f42279d8d4f724a81dd06fc79709af227064a477cd70e SHA512 4372570322682369f65317cbeb4e9b9dbcff3d8e5089a3bb3b8efa6cd461468a313793435fd5815fe18360984c44e6895c3c2a62e5e0b07eb0c3bf3532dbb1b2
diff --git a/net-libs/libproxy/libproxy-0.5.4.ebuild b/net-libs/libproxy/libproxy-0.5.4.ebuild
new file mode 100644
index 000000000000..9c74d75f82d7
--- /dev/null
+++ b/net-libs/libproxy/libproxy-0.5.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib vala
+
+DESCRIPTION="Library for automatic proxy configuration management"
+HOMEPAGE="https://github.com/libproxy/libproxy"
+SRC_URI="https://github.com/libproxy/libproxy/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="duktape gnome gtk-doc +introspection kde test vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.71.3:2[${MULTILIB_USEDEP}]
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+ duktape? (
+ dev-lang/duktape:=
+ net-misc/curl
+ )
+ introspection? ( dev-libs/gobject-introspection )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ kde? ( kde-frameworks/kconfig:5 )
+"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gi-docgen )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_setup
+ default
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_bool gtk-doc docs)
+ $(meson_use test tests)
+ -Dconfig-env=true
+ $(meson_use gnome config-gnome)
+ -Dconfig-windows=false
+ -Dconfig-sysconfig=true
+ -Dconfig-osx=false
+ $(meson_use kde config-kde)
+ $(meson_native_use_bool duktape pacrunner-duktape)
+ $(meson_native_use_bool vala vapi)
+ $(meson_use duktape curl)
+ $(meson_native_use_bool introspection)
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/${PN}-1.0 "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}