summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-08 09:36:41 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-08 10:42:17 +0100
commit24f47bb74f8989e3c9ec596e952c9e71f9f9643c (patch)
tree68803fe10cd71e6466dd416928907a9d0edc42a7
parentapp-admin/awscli: Bump to 1.22.50 (diff)
downloadgentoo-24f47bb74f8989e3c9ec596e952c9e71f9f9643c.tar.gz
gentoo-24f47bb74f8989e3c9ec596e952c9e71f9f9643c.tar.bz2
gentoo-24f47bb74f8989e3c9ec596e952c9e71f9f9643c.zip
dev-python/werkzeug: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-2.0.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 5d68236f74af..919d581150ae 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,2 +1,3 @@
DIST werkzeug-1.0.1.gh.tar.gz 907482 BLAKE2B d2dcdce8b1bcbb177b52b0915f2c0ac17d235dee3c77b23e81e4b35412d1f53a194d3c7c7f2a5c065ade99797effe72cc464cf6980b12c761a8a919338021660 SHA512 ba82120fb3e96e3a1334c6452d5ba1950fc016d2d147d643bbc2168ccec496f1dea799982ae8c578167155082c0bdbda5d56a23f64b4b6865f97e90e22df022e
DIST werkzeug-2.0.2.gh.tar.gz 896727 BLAKE2B 15506d57a8545eb45cb0f4efb78bcc4dfc1faa68910f09dfdd14f4bbb2404078247a7f61475c5fff9058a1557f7f6541eec262fb274e7ed82e1a82b9f644cf8b SHA512 789f210546c089e8a437a379e516147fd854806357938bd559a61855182143bdeca967c86a41d004e6adb119d31e4493e3c36e74aff989ee9cd08e48d1428dd9
+DIST werkzeug-2.0.3.gh.tar.gz 897523 BLAKE2B 1f97a2f7184e8e11bb85722becae7cc032ada38a642a2f925f7b81e89c881011889189999d50dab4591fc2e874aac4ab92b0f1531c211468cf352e31b0b8c8d0 SHA512 a205cd981b3e1b481436e483190427ff3808a5ea80abc616ca08d899d0e6a39893a5cb60adc65c99dcab3af47c24b321c71996d719cb7f224de7942b44b1fd69
diff --git a/dev-python/werkzeug/werkzeug-2.0.3.ebuild b/dev-python/werkzeug/werkzeug-2.0.3.ebuild
new file mode 100644
index 000000000000..17b310550b31
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-2.0.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://werkzeug.palletsprojects.com/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/"
+SRC_URI="
+ https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ !hppa? ( !ia64? (
+ $(python_gen_cond_dep '
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ ' 'python*')
+ ) )
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ !alpha? ( !hppa? ( !ia64? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ ) ) )
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ epytest -p no:django -p no:httpbin tests
+}