summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-03 13:40:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-03 13:48:42 +0300
commit24feb6d0810d596a6bcac874bec5b901389ba1d4 (patch)
tree14cd34f999baa4c17209bdfa196ba3d5609f07ec
parentdev-perl/MooseX-Getopt: add 0.760.0 (diff)
downloadgentoo-24feb6d0810d596a6bcac874bec5b901389ba1d4.tar.gz
gentoo-24feb6d0810d596a6bcac874bec5b901389ba1d4.tar.bz2
gentoo-24feb6d0810d596a6bcac874bec5b901389ba1d4.zip
app-shells/bash-completion: add 2.13.0
- add pytest-xdist for tests, for parallel testing - automatically extend symlinks for all supported python targets - fix CHANGES file rename - disable some more tests we don't really care about Closes: https://bugs.gentoo.org/886159 Closes: https://bugs.gentoo.org/622892 Closes: https://bugs.gentoo.org/836360 Closes: https://bugs.gentoo.org/734120 Closes: https://bugs.gentoo.org/669128 Bug: https://bugs.gentoo.org/865511 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-shells/bash-completion/Manifest1
-rw-r--r--app-shells/bash-completion/bash-completion-2.13.0.ebuild173
2 files changed, 174 insertions, 0 deletions
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index 886d43bc8301..52be88d63b02 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -1,2 +1,3 @@
DIST bash-completion-2.11.tar.xz 311004 BLAKE2B 98e3ab6669bd70b49b238a597f1bc1309dc7ddd51c5b17c5e054f9161115d75d26e85d547471bc087e070d10554448b790a6dfb557abc413b70079ecc94acce3 SHA512 41585f730b5114d397831ba36d10d05643c6a6179e746ddc49aa1cbef61ea5525fd2f09b2e474adee14e647f99df8d5983ee48e29a59d8a30e1daf7fb1837e06
+DIST bash-completion-2.13.0.tar.xz 424956 BLAKE2B 5055118378f99ea679cc9e6e2c12a2c82b3428bae3f87b2b73df448ce31c68567fc18423332fccd6f3c0c7ceb3ae8d0f0a84eec7ddbd8c2b7868061a03c4a8a5 SHA512 7c65fea599a25c2c9d6ef300a9cc2d5fbabd0bcc9e09fe32bb706d3398936f40501171f03280f042465bc0d9aca4b1b53c2c13a99bbdfb6fe916767a267158af
DIST bashcomp-2.0.3.tar.gz 3539 BLAKE2B 75304d144792cc7f6ad5455a05a65c33c646d6f7384d020a06a1fcf012cd51625a3dd0750ad539253453b1eede196c340286a1e81737f0835b5091609ba01295 SHA512 b2bd185ccbd4456939ccc731cc1983fcec2b9564a9920642a753fadd5d897fdb96b925ac1524657629d621d45b37d99076c8ae72511a827e96ff6c388d720008
diff --git a/app-shells/bash-completion/bash-completion-2.13.0.ebuild b/app-shells/bash-completion/bash-completion-2.13.0.ebuild
new file mode 100644
index 000000000000..e3dbaa5e5448
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-2.13.0.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+BASHCOMP_P=bashcomp-2.0.3
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-any-r1
+
+DESCRIPTION="Programmable Completion for bash"
+HOMEPAGE="https://github.com/scop/bash-completion"
+SRC_URI="
+ https://github.com/scop/bash-completion/releases/download/${PV}/${P}.tar.xz
+ eselect? (
+ https://github.com/projg2/bashcomp2/releases/download/v${BASHCOMP_P#*-}/${BASHCOMP_P}.tar.gz
+ )
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="+eselect test"
+RESTRICT="!test? ( test )"
+
+# completion collision with net-fs/mc
+RDEPEND="
+ >=app-shells/bash-4.3_p30-r1:0
+ sys-apps/miscfiles
+ !!net-fs/mc
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_any_dep '
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ ')
+ )
+"
+PDEPEND="
+ >=app-shells/gentoo-bashcomp-20140911
+"
+
+strip_completions() {
+ # Remove unwanted completions.
+ local strip_completions=(
+ # Slackware package stuff, quite generic names cause collisions
+ # (e.g. with sys-apps/pacman)
+ explodepkg installpkg makepkg pkgtool removepkg upgradepkg
+
+ # Debian/Red Hat network stuff
+ ifdown ifup ifquery ifstatus
+
+ # Installed in app-editors/vim-core
+ xxd
+
+ # Now-dead symlinks to deprecated completions
+ hd ncal
+
+ # FreeBSD
+ freebsd-update kldload kldunload portinstall portsnap
+ pkg_deinstall pkg_delete pkg_info
+ )
+
+ local file
+ for file in "${strip_completions[@]}"; do
+ rm "${ED}"/usr/share/bash-completion/completions/${file} ||
+ die "stripping ${file} failed"
+ done
+
+ # remove deprecated completions (moved to other packages)
+ rm "${ED}"/usr/share/bash-completion/completions/_* || die
+}
+
+python_check_deps() {
+ python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if use eselect; then
+ eapply "${WORKDIR}/${BASHCOMP_P}/bash-completion-blacklist-support.patch"
+ fi
+
+ eapply_user
+}
+
+src_test() {
+ local EPYTEST_DESELECT=(
+ # redhat-specific, we strip these completions
+ test/t/test_if{down,up}.py
+ # not available for icedtea
+ test/t/test_javaws.py
+ # TODO
+ test/t/test_vi.py::TestVi::test_2
+ test/t/test_xmlwf.py::TestXmlwf::test_2 #bug 886159
+ test/t/test_xrandr.py::TestXrandr::test_output_filter
+ )
+ local EPYTEST_IGNORE=(
+ # stupid test that async tests work
+ test/fixtures/pytest/test_async.py
+ )
+ local EPYTEST_XDIST=1
+
+ # portage's HOME override breaks tests
+ local -x HOME=$(unset HOME; echo ~)
+ addpredict "${HOME}"
+ # used in pytest tests
+ local -x NETWORK=none
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked
+ emake -C completions check
+ epytest
+}
+
+src_install() {
+ # work-around race conditions, bug #526996
+ mkdir -p "${ED}"/usr/share/bash-completion/{completions,helpers} || die
+
+ emake DESTDIR="${D}" profiledir="${EPREFIX}"/etc/bash/bashrc.d install
+
+ strip_completions
+
+ dodoc AUTHORS CHANGELOG.md CONTRIBUTING.md README.md
+
+ # install the python completions for all targets, bug #622892
+ local TARGET
+ for TARGET in "${PYTHON_COMPAT[@]}"; do
+ if [[ ! -e "${ED}"/usr/share/bash-completion/completions/${TARGET/_/.} ]]; then
+ dosym python "${ED}"/usr/share/bash-completion/completions/${TARGET/_/.}
+ fi
+ done
+
+ # install the eselect module
+ if use eselect; then
+ insinto /usr/share/eselect/modules
+ doins "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect"
+ doman "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect.5"
+ fi
+}
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 2.1-r90; then
+ ewarn "For bash-completion autoloader to work, all completions need to"
+ ewarn "be installed in /usr/share/bash-completion/completions. You may"
+ ewarn "need to rebuild packages that installed completions in the old"
+ ewarn "location. You can do this using:"
+ ewarn
+ ewarn "$ find ${EPREFIX}/usr/share/bash-completion -maxdepth 1 -type f '!' -name 'bash_completion' -exec emerge -1v {} +"
+ ewarn
+ ewarn "After the rebuild, you should remove the old setup symlinks:"
+ ewarn
+ ewarn "$ find ${EPREFIX}/etc/bash_completion.d -type l -delete"
+ fi
+ done
+
+ if has_version 'app-shells/zsh'; then
+ elog
+ elog "If you are interested in using the provided bash completion functions with"
+ elog "zsh, valuable tips on the effective use of bashcompinit are available:"
+ elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ elog
+ fi
+}