summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-12 19:10:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-12 19:14:03 +0200
commit24ff6c1b756098292b1ac5bae553d824b4c85203 (patch)
tree1729c60205cc3e07849ffdde6381d698bf9d3d47
parentros-meta/audio_common: Bump to 0.3.8. (diff)
downloadgentoo-24ff6c1b.tar.gz
gentoo-24ff6c1b.tar.bz2
gentoo-24ff6c1b.zip
dev-ros/diagnostic_aggregator: Bump to 1.10.2.
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/diagnostic_aggregator/Manifest1
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_aggregator/Manifest b/dev-ros/diagnostic_aggregator/Manifest
index db6b048d7735..4c635863e79d 100644
--- a/dev-ros/diagnostic_aggregator/Manifest
+++ b/dev-ros/diagnostic_aggregator/Manifest
@@ -1 +1,2 @@
DIST diagnostics-1.10.1.tar.gz 536607 BLAKE2B 6a69163fbf60820839f1fc7071b6ea9df7b70cc2979b42648ac56d0acce820af69595b2a9e4d11b9752d4d85bd19276ccfcb6a57a523e7d69354fbc64414fec4 SHA512 a45d41a0ba3b879ab3228bc3d3152cd59d7145b96f9a5b1798eb1d9aaba8dbd6234ec3692c1a84289d0f543eed3adb0ca4dcbd1f1b6ceaef54af7866e1ad9ee7
+DIST diagnostics-1.10.2.tar.gz 536910 BLAKE2B da4de61798d0022114573ca7360f48afe0a7b62f56ac2e9830182dfd0cdaf2f7985b549807028360d8edd97ec3630465eef0d02c51333ffedf0809f235a11f26 SHA512 5a88cfe6f2bc71ae71e3d7aad6c83c6ac17fb2e072b8ba1ba97b86cb8e6f7373ba2c4b6889d0253f062119c86459880485b1afc682747f91c2eb7acdb9e71d3c
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.2.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.2.ebuild
new file mode 100644
index 000000000000..76db5fae27db
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates ROS diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/pluginlib:=
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+ dev-ros/xmlrpcpp
+ dev-ros/bondcpp
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+ dev-ros/bondpy[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH="${BUILD_DIR}/devel/:${CATKIN_PREFIX_PATH}"
+ ros-catkin_src_test
+}