summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2021-04-24 02:10:24 -0500
committerMatthias Maier <tamiko@gentoo.org>2021-04-24 02:14:21 -0500
commit25030f5784dd96bb2c66e22374df1b1d5f48b029 (patch)
treed26aa5711b106df30f2bac47f20a67060ced2aa5
parentsci-libs/dealii: update dependency (diff)
downloadgentoo-25030f5784dd96bb2c66e22374df1b1d5f48b029.tar.gz
gentoo-25030f5784dd96bb2c66e22374df1b1d5f48b029.tar.bz2
gentoo-25030f5784dd96bb2c66e22374df1b1d5f48b029.zip
sci-libs/sundials: version bump to 5.7.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--sci-libs/sundials/Manifest1
-rw-r--r--sci-libs/sundials/files/sundials-5.7.0-fix-license-install-path.patch17
-rw-r--r--sci-libs/sundials/sundials-5.7.0.ebuild77
3 files changed, 95 insertions, 0 deletions
diff --git a/sci-libs/sundials/Manifest b/sci-libs/sundials/Manifest
index 8e2bf49a6617..f28af30da2f7 100644
--- a/sci-libs/sundials/Manifest
+++ b/sci-libs/sundials/Manifest
@@ -1,2 +1,3 @@
DIST sundials-3.2.1.tar.gz 14958699 BLAKE2B ecc4b454ec589e9177acc9375e1db370ad6281f8d29580d9558ad3146dbbaab52794013e9cb56ad83f7309dbd3084a1ccaf6972c6b1468cefcc86bf30d3a460c SHA512 1f3e4b12f368e4f50c38b970c012f1702e339319ee0a858661bdf83e5739bb5b8a36f98b82e2ef76d1ce8a473123046347ee1b44f3cb685509823864f0af1384
DIST sundials-5.2.0.tar.gz 18639221 BLAKE2B c10e6deb5839993b8601347be94412d0b0c058084b4dc0d380681f7b4debd535f9736c2ef734e9fd84c6ddc190ab05f46abcb711225ec1f156a18d8edb6317fb SHA512 99163a104e436dab4779c77519502b5614b65d726324b29b14236315f6916beb5863fcd56b5acf19f62985c033b227fba1ebd3d3c4607ce991d94ee7739bb55f
+DIST sundials-5.7.0.tar.gz 22612286 BLAKE2B a21db0d07b8f2056ba244ca52f13bde51a2f745535c7381a4eecf9d8037df3d50f010c8fecd8e37d71150f101c8177b2e3f0ffbed8139702993e01b8ad52e707 SHA512 5e2b6145fdaa72e7d13f43e75e5bc08b9d7eb5b9e048207d5772ddab767e198af5be24b73a942a564a49d56ca0b47fe6493bd2de34a8a93948ccd1c13e5dd170
diff --git a/sci-libs/sundials/files/sundials-5.7.0-fix-license-install-path.patch b/sci-libs/sundials/files/sundials-5.7.0-fix-license-install-path.patch
new file mode 100644
index 000000000000..88fb964f8995
--- /dev/null
+++ b/sci-libs/sundials/files/sundials-5.7.0-fix-license-install-path.patch
@@ -0,0 +1,17 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 40a650e..2133476 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -231,10 +231,10 @@ endif()
+
+ # install license and notice files
+ install(FILES "${PROJECT_SOURCE_DIR}/LICENSE"
+- DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/sundials"
++ DESTINATION share/doc/sundials-5.7.0
+ )
+ install(FILES "${PROJECT_SOURCE_DIR}/NOTICE"
+- DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/sundials"
++ DESTINATION share/doc/sundials-5.7.0
+ )
+
+ # create package version file
diff --git a/sci-libs/sundials/sundials-5.7.0.ebuild b/sci-libs/sundials/sundials-5.7.0.ebuild
new file mode 100644
index 000000000000..de4ffc5ebcaf
--- /dev/null
+++ b/sci-libs/sundials/sundials-5.7.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD="77 90"
+# if FFLAGS and FCFLAGS are set then should be equal
+
+inherit cmake fortran-2 toolchain-funcs flag-o-matic
+
+DESCRIPTION="Suite of nonlinear solvers"
+HOMEPAGE="https://computation.llnl.gov/projects/sundials"
+SRC_URI="https://github.com/LLNL/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cxx doc examples fortran hypre lapack mpi openmp sparse static-libs superlumt threads"
+REQUIRED_USE="hypre? ( mpi )"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ lapack? ( virtual/lapack )
+ mpi? ( virtual/mpi sci-libs/hypre:= )
+ sparse? ( sci-libs/klu )
+ superlumt? ( sci-libs/superlu_mt:= )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-license-install-path.patch )
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp && [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+}
+
+src_prepare() {
+ # bug #707240
+ append-cflags -fcommon
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ mycmakeargs+=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_STATIC_LIBS="$(usex static-libs)"
+ -DCXX_ENABLE="$(usex cxx)"
+ -DFCMIX_ENABLE="$(usex fortran)"
+ -DF90_ENABLE="$(usex fortran)"
+ -DHYPRE_ENABLE="$(usex hypre)"
+ -DHYPRE_INCLUDE_DIR="${EPREFIX}/usr/include/hypre"
+ -DKLU_ENABLE="$(usex sparse)"
+ -DLAPACK_ENABLE="$(usex lapack)"
+ -DMPI_ENABLE="$(usex mpi)"
+ -DOPENMP_ENABLE="$(usex openmp)"
+ -DPTHREAD_ENABLE="$(usex threads)"
+ -DSUPERLUMT_ENABLE="$(usex superlumt)"
+ -DSUPERLUMT_INCLUDE_DIR="${EPREFIX}/usr/include/superlu_mt"
+ -DSUPERLUMT_LIBRARY="-lsuperlu_mt"
+ -DEXAMPLES_ENABLE="$(usex examples)"
+ -DEXAMPLES_INSTALL=ON
+ -DEXAMPLES_INSTALL_PATH="/usr/share/doc/${PF}/examples"
+ -DUSE_GENERIC_MATH=ON
+ )
+ use sparse && mycmakeargs+=( -DKLU_LIBRARY="${EPREFIX}/usr/$(get_libdir)/libklu.so" )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ use doc && dodoc doc/*/*.pdf
+}