summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-05 09:11:34 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-05 10:27:20 +0200
commit2505f991bea5b748fe798e2f194a0e7e6770834f (patch)
treeaf0afb191db457342cf679f18bb654a58c264ef4
parentdev-python/jupyter_server: Bump to 1.11.1 (diff)
downloadgentoo-2505f991.tar.gz
gentoo-2505f991.tar.bz2
gentoo-2505f991.zip
dev-python/pybind11: Bump to 2.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pybind11/Manifest1
-rw-r--r--dev-python/pybind11/pybind11-2.8.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index 96f96ba6b103..8e6050c7d18a 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1 +1,2 @@
DIST pybind11-2.7.1.tar.gz 668217 BLAKE2B 92d857f14290ee0717bd9f9b871dcecd6c0b36209bb9879f107c8542326fb0cc42c051f3bc12a8be50df892f1e26c26b710f60ed275f0dff206e30149547f2b4 SHA512 f09f46622b394d3990ab82aa7ea15a06e298df109cd2df263ba9d6ac7fb248217df7450e1954a9679a8360335d5bbf662926a34c8b7c61b6e4c396bbdfd88305
+DIST pybind11-2.8.0.tar.gz 688544 BLAKE2B 3652ebf56cdec9c50a431915b4b59cd7c61d58be5a521dd2bea20ea9a0e56ae8782400d4460a5e32f3c3ec086709ee466b6b39c6adc5cd712da05b4016f9f2e1 SHA512 2f066ab1a3d4a22513625f52b55d7722f953007876e800b4a08d6341b9ae70f73a3b0fd57f76cee443e7b8cf0eecdaafc032a23ddad2b8bca2c8108ac4090a82
diff --git a/dev-python/pybind11/pybind11-2.8.0.ebuild b/dev-python/pybind11/pybind11-2.8.0.ebuild
new file mode 100644
index 000000000000..3edf9adb8aa7
--- /dev/null
+++ b/dev-python/pybind11/pybind11-2.8.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="https://pybind11.readthedocs.io/en/stable/"
+SRC_URI="https://github.com/pybind/pybind11/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ dev-cpp/eigen:3
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ export PYBIND11_USE_CMAKE=1
+
+ cmake_src_prepare
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ local mycmakeargs=(
+ # disable forced lto
+ -DPYBIND11_LTO_CXX_FLAGS=
+ -DPYBIND11_INSTALL=ON
+ -DPYBIND11_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Compilation only does anything for tests
+ use test && cmake_src_compile
+}
+
+python_test() {
+ cmake_build check
+}
+
+python_install() {
+ distutils-r1_python_install
+ cmake_src_install
+}