summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-02 15:33:45 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-02 15:54:20 +0100
commit25085f9ab7330acdb4130d0b80dce9999046ea3b (patch)
treef8e7fc1220287f750dbb2fc6a61453d095650879
parentdev-python/Nuitka: Remove old (diff)
downloadgentoo-25085f9a.tar.gz
gentoo-25085f9a.tar.bz2
gentoo-25085f9a.zip
dev-python/Nuitka: Bump to 1.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-1.3.5.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 18e0bb2fddf9..048ae79cf736 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-1.3.4.tar.gz 4028710 BLAKE2B 5cf02644524f612cd4403147323ce0e4d121efd91d8a9da3f55e81117e088337ce9d56f801691b52236bb17bb7ffc3987e98c8d23bad1c84b4bae61fae41b5cd SHA512 7c3562a264833ba2b5ed09a43d91113f59ece8a088480ac03517fe66b380d354faf465845fb7218d34f328114d8bdee92d4374651182f85f50593ce9294e8796
+DIST Nuitka-1.3.5.tar.gz 4019765 BLAKE2B dc169a318400e23021a2712f41c49e8d045352c2b6ab946a289d479ee3aeb887456cb0218e762ea091885ce4204d1c3d59e6d228a58b596a70387400e5f31c35 SHA512 edc603b3b38e68473d3002641e61d969cd1fe9626aaa45023c017b2c2ed288d61ee5e537e9b96ca53efc5e052e689df37849bb0b1da65d0b31d38152645ced25
diff --git a/dev-python/Nuitka/Nuitka-1.3.5.ebuild b/dev-python/Nuitka/Nuitka-1.3.5.ebuild
new file mode 100644
index 000000000000..3ad289dde538
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.3.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}