summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-10 20:54:50 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-10 20:58:22 +0200
commit251defce6384dd328fa0a53c26a737b3a3974f62 (patch)
tree8ca342b0ca3f893d7a8c41e8057eb0fe12fa745d
parentvirtualbox packages: Removed old. (diff)
downloadgentoo-251defce.tar.gz
gentoo-251defce.tar.bz2
gentoo-251defce.zip
net-firewall/nftables: Bump to version 0.8.5
Closes: https://bugs.gentoo.org/655412 Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--net-firewall/nftables/Manifest1
-rw-r--r--net-firewall/nftables/nftables-0.8.5.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/net-firewall/nftables/Manifest b/net-firewall/nftables/Manifest
index 3ad77dd5b26b..fd3b9ea098c0 100644
--- a/net-firewall/nftables/Manifest
+++ b/net-firewall/nftables/Manifest
@@ -1,3 +1,4 @@
DIST nftables-0.8.3.tar.gz 336963 BLAKE2B 534768559254d1c797ae84d97487dfca12bd2ab07170a8670778b46c7a6c854858b8ac670eedb0d0c443b457b4ad15d03c0a6b54ffa5ecde78ef538df71ec090 SHA512 cffea523fe2eee5937f30fe3d5215e5890dfc089d6f16d07090ef922e2782df53fe268d467734a1b6a604d7f16bca52ada3e48cce7699a59dd7a092294930332
DIST nftables-0.8.4.tar.gz 353236 BLAKE2B 78d35880ea6cb9af2f9ed99134c930cb8bfa6290e2adee28e2147bab676ebef420db04e2eba6b8bc541c7afc040461c194e01e45f176cfbb663e04d6347bf119 SHA512 79cbf7098343cdb517a1790a72769738756eca499eb84aa7ad0b6c96314502f09ac4d03a712bfbe45fc1b8a730f2f56c6ef515e8d93d24f065a55e0594ab62bd
+DIST nftables-0.8.5.tar.gz 355403 BLAKE2B 124bc5c35f050cc591f57b39cddcd595f97d14f83aed464b42efed272a03150623667dd0ca2862833c6b86d825d264c79dd1a211b9a6913b5734c0eaa4029b13 SHA512 311ec77646e2bc7da1b46ef2aba7492a5c0fdf23d33633649a6304771c5ce5ad839353b0702e942a82508c01d1c35705b602d91e54913944e03e176dc3f855f8
DIST nftables-0.8.tar.gz 327629 BLAKE2B a484c22ac010f68fc7458c12cabd0c35e474a0bf81fa4edbefba12d75b424898d38adb11a7fbb4542efbbb2d14be823701b3d9ced7b9fd669338366733fa169b SHA512 90ffebc338c121334ca42822793b6fdeff48390e755c690308919de47064b53f9af735a2c2914e5255f1bddec90484599337d4cdd67f7a01a3956deefcef9fcb
diff --git a/net-firewall/nftables/nftables-0.8.5.ebuild b/net-firewall/nftables/nftables-0.8.5.ebuild
new file mode 100644
index 000000000000..cc5cb45fc15d
--- /dev/null
+++ b/net-firewall/nftables/nftables-0.8.5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="Linux kernel (3.13+) firewall, NAT and packet mangling tools"
+HOMEPAGE="https://netfilter.org/projects/nftables/"
+SRC_URI="https://git.netfilter.org/nftables/snapshot/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~x86"
+IUSE="debug doc +gmp +readline"
+
+RDEPEND=">=net-libs/libmnl-1.0.3:0=
+ gmp? ( dev-libs/gmp:0= )
+ readline? ( sys-libs/readline:0= )
+ >=net-libs/libnftnl-1.1.0:0="
+
+DEPEND="${RDEPEND}
+ >=app-text/docbook2X-0.8.8-r4
+ doc? ( >=app-text/dblatex-0.3.7 )
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig"
+
+S="${WORKDIR}/v${PV}"
+
+pkg_setup() {
+ if kernel_is ge 3 13; then
+ CONFIG_CHECK="~NF_TABLES"
+ linux-info_pkg_setup
+ else
+ eerror "This package requires kernel version 3.13 or newer to work properly."
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --sbindir="${EPREFIX}"/sbin
+ $(use_enable doc pdf-doc)
+ $(use_enable debug)
+ $(use_with readline cli)
+ $(use_with !gmp mini_gmp)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ exeinto /usr/libexec/${PN}
+ doexe "${FILESDIR}"/libexec/${PN}.sh
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+ keepdir /var/lib/nftables
+
+ systemd_dounit "${FILESDIR}"/systemd/${PN}-restore.service
+ systemd_enable_service basic.target ${PN}-restore.service
+}
+
+pkg_postinst() {
+ local save_file
+ save_file="${EROOT%/}/var/lib/nftables/rules-save"
+
+ # In order for the nftables-restore systemd service to start
+ # the save_file must exist.
+ if [[ ! -f ${save_file} ]]; then
+ touch ${save_file}
+ fi
+
+ elog "If you are creating firewall rules before the next system restart "
+ elog "the nftables-restore service must be manually started in order to "
+ elog "save those rules on shutdown."
+}