summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-13 09:35:04 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-13 11:05:42 +0200
commit253628f82b38126cc80657b894905dc071b5be3d (patch)
tree8ff8189ee5074b6dafb6685160edee5dd6ca91b8
parentdev-python/importlib_metadata: Bump to 3.10.1 (diff)
downloadgentoo-253628f82b38126cc80657b894905dc071b5be3d.tar.gz
gentoo-253628f82b38126cc80657b894905dc071b5be3d.tar.bz2
gentoo-253628f82b38126cc80657b894905dc071b5be3d.zip
dev-python/botocore: Bump to 1.20.50
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.50.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index df99f6c7cd81..782e36290fd7 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.20.33.tar.gz 7543656 BLAKE2B eefd7b06c5a43780982616cfd640c6a1c5d9e919b403c0f78be06833e8e618b142cabacf2dd3b3e13cf351bbd5d0d42ef23b314355f68f7d9dc6aa9cae6e377f SHA512 6354ed7ebbe467ea96c0ea0e059acd2be0a40973d55998c0e006e73a67f2a69bd8009099f761af83e47022ad27698d3a21ffc2824ad4b74a687bc490239420e0
DIST botocore-1.20.44.tar.gz 7596878 BLAKE2B 935d4ea1c5212d29566c3344761b00d2eb03e7588bd7805072926ecd41f0fa03cd91e25802dc63078190c49f1b8503545bd0b2a88d702c04a961d57a0022080f SHA512 eb7ae15bac4ae8ad516ebcd8166f65a809d7d02c11dde25b714f7bf673ecfeef9ea414ab4b53ac428ac948ee8b054666ba2f6c0a96e6d148ff46d94e6100350d
DIST botocore-1.20.49.tar.gz 7630973 BLAKE2B 89d10ece5cd645d6904046804c2b2d789d7d09c2aa231856f7b5529f54a4933c2bdcc800a64d3bbc27d9f4a7de7debcb3fbc37ead1923b7fa3dbb44b40dd97e8 SHA512 994f9ee04d0b7c99aee12be5823c29fdafe145b7db71df765ba798ba33650b2189fbbfd274aec1051a7e9be1d1ac0ebf19b61ce4d8afd98635e108bbb2c63351
+DIST botocore-1.20.50.tar.gz 7632505 BLAKE2B e52668e217d7dd9769df9cd8e45ee6b50dbc7c4e2f5cc2e05006e9770b45a10bf4f952fa2365511c92223e38b8a440950495ba435cd1a52b190f43f39a56ee73 SHA512 b6d564852d832269be9a553aa629fa5ec77185e997ebe6df16bbd5bd738982ddd8f25378d52286abb24f49bcc494829b9a40735125d62750878534f70c5b718e
diff --git a/dev-python/botocore/botocore-1.20.50.ebuild b/dev-python/botocore/botocore-1.20.50.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.50.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}