summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2021-11-30 01:02:54 +0100
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2021-11-30 01:20:24 +0100
commit2583fe786439a55fd4f6517388a2eb4f0118870b (patch)
treea722ebbdb6e261494086a03cc1140611c17aa7e1
parentdev-lang/python: Remove old (diff)
downloadgentoo-2583fe786439a55fd4f6517388a2eb4f0118870b.tar.gz
gentoo-2583fe786439a55fd4f6517388a2eb4f0118870b.tar.bz2
gentoo-2583fe786439a55fd4f6517388a2eb4f0118870b.zip
net-misc/usbip: bump to 5.15
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
-rw-r--r--net-misc/usbip/Manifest1
-rw-r--r--net-misc/usbip/usbip-5.15.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/net-misc/usbip/Manifest b/net-misc/usbip/Manifest
index a25d0457052b..9d29974f4086 100644
--- a/net-misc/usbip/Manifest
+++ b/net-misc/usbip/Manifest
@@ -1 +1,2 @@
DIST linux-4.13.tar.xz 100579888 BLAKE2B 2f8be07d403071b097b019c43fa332bc7d4805dee633a6fdffe5a99d5475015ca9e4881e7f4cbfd36f8c451bacf423436364ea3d9f25b8723a29a178dededb2b SHA512 a557c2f0303ae618910b7106ff63d9978afddf470f03cb72aa748213e099a0ecd5f3119aea6cbd7b61df30ca6ef3ec57044d524b7babbaabddf8b08b8bafa7d2
+DIST linux-5.15.tar.xz 121913744 BLAKE2B 3921274b23f7938abdf3ed9334534b4581e13d7484303d3a5280eddb038999aaa8b836666a487472d9c4a219af0f06b9fecccaf348fb5510ab8762f4ef4b7e83 SHA512 d25ad40b5bcd6a4c6042fd0fd84e196e7a58024734c3e9a484fd0d5d54a0c1d87db8a3c784eff55e43b6f021709dc685eb0efa18d2aec327e4f88a79f405705a
diff --git a/net-misc/usbip/usbip-5.15.ebuild b/net-misc/usbip/usbip-5.15.ebuild
new file mode 100644
index 000000000000..3fcee65007b6
--- /dev/null
+++ b/net-misc/usbip/usbip-5.15.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ETYPE="sources"
+K_NOUSENAME=1
+inherit autotools kernel-2
+
+DESCRIPTION="Userspace utilities for a general USB device sharing system over IP networks"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="${KERNEL_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tcpd"
+
+RDEPEND="
+ >=dev-libs/glib-2.6
+ sys-apps/hwdata
+ >=sys-kernel/linux-headers-3.17
+ virtual/libudev
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/linux-${PV}/tools/usb/${PN}"
+
+src_unpack() {
+ tar xJf "${DISTDIR}"/${A} linux-${PV}/tools/usb/${PN} || die
+}
+
+src_prepare() {
+ default
+ # remove -Werror from build, bug #545398
+ sed -i 's/-Werror[^ ]* //g' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use tcpd || echo --without-tcp-wrappers) \
+ --with-usbids-dir="${EPREFIX}"/usr/share/hwdata
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "For using USB/IP you need to enable USBIP_VHCI_HCD in the client"
+ elog "machine's kernel config and USBIP_HOST on the server."
+}