summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-16 18:04:45 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-16 18:13:49 -0400
commit258970bdf9cd7b5b821b90d896f8407edfd0852f (patch)
tree0d26cd308f56fd54b77dff8c360d24ff9a085df5
parentpackage.mask: revert "Last-rite dev-haskell/wx{,c,core}" (diff)
downloadgentoo-258970bd.tar.gz
gentoo-258970bd.tar.bz2
gentoo-258970bd.zip
sci-geosciences/gnome-maps: Version bump to 40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-40.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index f82b62426183..e046e78752f3 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1 +1,2 @@
DIST gnome-maps-3.36.6.tar.xz 4006804 BLAKE2B 4d7684a13b5bace21e7a9d6b97b9b4b91a6fc5cbdbc98c1a776f157c5b1747b16669602e6167afd254d4fe72f8c4d7c9ac27c22089efd07839a6f35bf68b1c31 SHA512 bd72ede45edf851fdbd815278838c34b42145fcccb18bd33ff5e732238797eadc0fe4e0279072c0dd9bfd7b5d88329d8e537ceb3072e186fbc213d63cdef1e72
+DIST gnome-maps-40.0.tar.xz 3540952 BLAKE2B c41a79ce5966a3dac903caa7b98651b7734d8a55b37de5e330e34dd0db0f146a6ca247c82a8d0f07ec5f55b1efaf40d6f86d4fc35ff750f09a565c0edcde6702 SHA512 6ace3c43b1578b278e39fd27dabe9ab62a4ae80ecf1fb42fe3b8e3e208d43e6fd3325b4c61c6de7c05fcc3321178d556d8fafe0e6d2c7c0a924248b9832fa25e
diff --git a/sci-geosciences/gnome-maps/gnome-maps-40.0.ebuild b/sci-geosciences/gnome-maps/gnome-maps-40.0.ebuild
new file mode 100644
index 000000000000..4c47cd1175bd
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-40.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Pure introspection dependencies found by grepping imports.gi in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ x11-libs/pango[introspection]
+ >=dev-libs/gjs-1.66.0
+ >=dev-libs/gobject-introspection-0.10.1:=
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libhandy-0.84:1=
+ >=dev-libs/libgee-0.16:0.8[introspection]
+ >=dev-libs/folks-0.10
+ >=sci-geosciences/geocode-glib-3.15.2[introspection]
+ >=media-libs/libchamplain-0.12.14:0.12[gtk,introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.7.90:0.7[introspection]
+
+ app-crypt/libsecret[introspection]
+ dev-libs/libgweather[introspection]
+ media-libs/clutter-gtk:1.0[introspection]
+ media-libs/clutter:1.0[introspection]
+ net-libs/gnome-online-accounts[introspection]
+ net-libs/libgfbgraph[introspection]
+ net-libs/libsoup:2.4[introspection]
+ net-libs/webkit-gtk:4[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}