summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-03 00:02:46 +0000
committerSam James <sam@gentoo.org>2022-01-03 00:10:37 +0000
commit2589b4b866b4649714559a4d05e8b5c04e37c7a1 (patch)
treec150af1c6ca51fce5f8a540a41df486a718607f9
parentsys-apps/policycoreutils: Specify policy root path correctly (diff)
downloadgentoo-2589b4b8.tar.gz
gentoo-2589b4b8.tar.bz2
gentoo-2589b4b8.zip
net-analyzer/alive: add 2.0.5
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/alive/Manifest1
-rw-r--r--net-analyzer/alive/alive-2.0.5.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/alive/Manifest b/net-analyzer/alive/Manifest
index d83780149093..87f824415e95 100644
--- a/net-analyzer/alive/Manifest
+++ b/net-analyzer/alive/Manifest
@@ -1,2 +1,3 @@
DIST alive-2.0.3.tar.xz 187396 BLAKE2B 0614ae8d0707abf59dd1500d986ce21221092d118a40ae92e838bd11b81a2b5fd261a531843f99992746a86a31bbb494a9f35f9fa0ad5c0ea896d68edec17205 SHA512 3b2f14d84682466e02fc6678ba26eb4c0b9378f1c938a7463cc5736501cbf144baaeb7dea2c8343a916891ce4e2d580bac946c913c01d7c25e12bfa611c89422
DIST alive-2.0.4.tar.lz 185849 BLAKE2B 34d2a29ea084b4bed960169fbf3d20377e79b56c183f1a3c1a05b6eb0a45a388267354d1740b7a9d63ff87281213e424362acb0f74b6d9351dbfad209b427edc SHA512 64842286fbe1ccd4d44d20610443fc5f5a2aef2acaef4d79e56ed9b6064f87ddd8af4dfb96b4a425a6cc28f8c741dbcda6ae86adbc5be86cb5c5925d7897e3c6
+DIST alive-2.0.5.tar.lz 186304 BLAKE2B 8528d7b86030ff0b54cd391a7cd7b42be974d5f605c66c6340468855959d2adf31940312d6693580839e9180813a3e96c2fe86a3842f3abd00af0e08b7f301ee SHA512 f760f9386019ddeac8690eec9119d557d4e288cc8698ce69adc8d9915eb0bc27fcf4015e9c4710411321d21c11731e61be754e9b827dceceab6463e531ed4240
diff --git a/net-analyzer/alive/alive-2.0.5.ebuild b/net-analyzer/alive/alive-2.0.5.ebuild
new file mode 100644
index 000000000000..567f090930f3
--- /dev/null
+++ b/net-analyzer/alive/alive-2.0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools unpacker
+
+DESCRIPTION="A periodic ping program"
+HOMEPAGE="https://www.gnu.org/software/alive/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+DEPEND="dev-scheme/guile"
+RDEPEND="${DEPEND}
+ dev-scheme/xdgdirs
+ net-misc/iputils"
+BDEPEND="$(unpacker_src_uri_depends)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.2-ping-test.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}