summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-01-02 07:58:45 +0100
committerHans de Graaff <graaff@gentoo.org>2023-01-02 07:59:19 +0100
commit25ad41c9cdad5eb264f181ca1b8de38566fe3b16 (patch)
treee47afed5b3934701e08beb2bead66baf7910d96b
parentwww-servers/puma: add 6.0.2 (diff)
downloadgentoo-25ad41c9.tar.gz
gentoo-25ad41c9.tar.bz2
gentoo-25ad41c9.zip
dev-ruby/httparty: add 0.21.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/httparty/Manifest1
-rw-r--r--dev-ruby/httparty/httparty-0.21.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/httparty/Manifest b/dev-ruby/httparty/Manifest
index bdc9e4a01f1e..5cd616b80b71 100644
--- a/dev-ruby/httparty/Manifest
+++ b/dev-ruby/httparty/Manifest
@@ -1 +1,2 @@
DIST httparty-0.20.0.tar.gz 101975 BLAKE2B f15eb837a4bbc98de501e6dcca5a17bb0906e8ea6671c55a85d665659ab60bcee5e84d9dafad6b2450e22cedfaf5a86e10e077e52b1120ff9ae2613a1176a651 SHA512 f5770d5a64be2e80aa70334dad899fb723b08088a673a788ca1402285b77ae6b3cef21e3ed263d9618a32879711c9183f2dc82ff7b50bcf6439a8e6bb7a2eb4e
+DIST httparty-0.21.0.tar.gz 102735 BLAKE2B 131c4f3a5a403b609391ececaf079de5ed5c57ea4660fc1d1041832d8baa27b8beaf11ac2743aa6059005904d787259afec27597744bb5e35e56c3b035ca4b1b SHA512 afd50de88a6b1e1cac8c90d6e1458c41ef122b4542c3a14274aacb052f9ceafad868d1b2582d45eedd212a8037fac13238ac05c2e661c9ba9196a00ef3a0a634
diff --git a/dev-ruby/httparty/httparty-0.21.0.ebuild b/dev-ruby/httparty/httparty-0.21.0.ebuild
new file mode 100644
index 000000000000..bc2ccb2f5ffe
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.21.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="httparty.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
+HOMEPAGE="https://jnunemaker.github.com/httparty"
+SRC_URI="https://github.com/jnunemaker/httparty/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/mini_mime-1.0.0 >=dev-ruby/multi_xml-0.5.2'
+
+ruby_add_bdepend 'test? ( dev-ruby/webmock )'
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files \?-\?-\?/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid test dependency on cucumber. We can't run the features since
+ # they depend on mongrel which is no longer packaged.
+ sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+
+ # Avoid test dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '/pry/ s:^:#:' \
+ -e '1i require "cgi"; require "delegate"' spec/spec_helper.rb || die
+
+ # Avoid test that works standalone but fails in the suite
+ #sed -i -e '/calls block given to perform with each redirect/,/^ end/ s:^:#:' spec/httparty/request_spec.rb
+
+ # Avoid test that is not fully compatible with newer multi_xml
+ sed -i -e '/should be able parse response type xml automatically/askip "multi_xml"' spec/httparty_spec.rb || die
+
+ # Avoid test that fails due to unicode normalization differences
+ sed -i -e '/handles international domains/askip "unicode differences"' spec/httparty_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}