summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-01 22:11:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-01 22:26:26 +0100
commit25d32acab860cbaefd6001687fb519aadc66e0d4 (patch)
tree6d3875f21ea3c1f4e01da1f8b72b0d946768f982
parentprofiles: drop unnecessary sys-devel/gcc[hardened] mask (diff)
downloadgentoo-25d32aca.tar.gz
gentoo-25d32aca.tar.bz2
gentoo-25d32aca.zip
app-text/poppler: 23.01.0 version bump, raise various min versions
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-text/poppler/Manifest2
-rw-r--r--app-text/poppler/poppler-23.01.0.ebuild134
-rw-r--r--app-text/poppler/poppler-9999.ebuild16
3 files changed, 144 insertions, 8 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index fbf77edbefbd..4de27cf2bc88 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -2,3 +2,5 @@ DIST poppler-22.11.0.tar.xz 1845444 BLAKE2B 958eb5e99725e46f3fd79138f4e1197ede9d
DIST poppler-22.11.0.tar.xz.sig 833 BLAKE2B 8ebe07b5276272a29b9e7a427c066fb76a84c3ee1b7e259ddffe396c9c7798bb35092c2712e4d2d1f1ca6ec5226cf876717fb6858fe83cca1c39db25e231e1c9 SHA512 dabfbcb6bfde638fce6019a028e0d20951169a21751eb2474e67523800973a65dcb47855c8a908946026e3676cf0b1f782bcdd780fd5da0f035576df54610403
DIST poppler-22.12.0.tar.xz 1845856 BLAKE2B 73003b19b21ab7ed8ce4de813fcfc4b22dcae19669a107e6618d8784958da55cfa93b2045988e45f7ffae918930560fa9e8afeabb6fae8b2a48ddafdf5d4f4d2 SHA512 5ebfa3920922a94a1ae67aa179c0003df498c018d1c3850568637b966c6cf670ff221b4225e875e1c531d6b7d7e06a63a19b9fbe3ac1f589441aaebf23ca8a09
DIST poppler-22.12.0.tar.xz.sig 833 BLAKE2B 370e8079f8d703d1c5f674e513dc849fa1747adf440178c25e09b4a075eaa47924ad75821f176d9f692d0167ce08f683bf67b71b8e75c43fe9e1e9addf820d48 SHA512 305ee75a40612018edc44cbdffa126d3033bc900f62636babc8b6638a689e14567830a1d26b5e303ac303cb5e3d9c10bf331493754ab5ef4074fd17521bf06e6
+DIST poppler-23.01.0.tar.xz 1847492 BLAKE2B 8dd85767a0c101b3d7166719374658a233aff491b0990917aacaa6fb3c5d8e51104b3ac45c78dcfb380286ea48067d1db57c2794d99a93cae9f4d64e9ca3dd07 SHA512 a44fd59cdb4dc1c04765990d9666f27538895883fe98a64e7bea30caebeab10875615282307fbd6eacecf83b7a7c8daa81afa1b13ae6c09b80673e3fb8563053
+DIST poppler-23.01.0.tar.xz.sig 833 BLAKE2B 46c3910627fd69930fd428397e739e3fe41c9b835379dfe7abbdf421049a77b33ce1cf6a44bd386278d3610ae2547d119ac6da4c3bfa7f348c51fbce7319a878 SHA512 0cebaac1846e6b3944175bcb28b49592d562738c009a97e048abe9f6677718c97bea2b470ea503b8dd083fc5f154e71d539cf1e3bce08363c6979d268dcdfd3b
diff --git a/app-text/poppler/poppler-23.01.0.ebuild b/app-text/poppler/poppler-23.01.0.ebuild
new file mode 100644
index 000000000000..eafad6c41cf7
--- /dev/null
+++ b/app-text/poppler/poppler-23.01.0.ebuild
@@ -0,0 +1,134 @@
+# Copyright 2005-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs xdg-utils
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/poppler/poppler.git"
+ SLOT="0/9999"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/aacid.asc
+ inherit verify-sig
+
+ SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
+ SRC_URI+=" verify-sig? ( https://poppler.freedesktop.org/${P}.tar.xz.sig )"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SLOT="0/126" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+fi
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="https://poppler.freedesktop.org/"
+
+LICENSE="GPL-2"
+IUSE="boost cairo cjk curl +cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt5 tiff +utils"
+
+# No test data provided
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=media-libs/fontconfig-2.13
+ >=media-libs/freetype-2.10
+ sys-libs/zlib
+ cairo? (
+ >=dev-libs/glib-2.64:2
+ >=x11-libs/cairo-1.16
+ introspection? ( >=dev-libs/gobject-introspection-1.64:= )
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ jpeg2k? ( >=media-libs/openjpeg-2.3.0-r1:2= )
+ lcms? ( media-libs/lcms:2 )
+ nss? ( >=dev-libs/nss-3.19:0 )
+ png? ( media-libs/libpng:0= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtxml:5
+ )
+ tiff? ( media-libs/tiff:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ cjk? ( app-text/poppler-data )
+"
+DEPEND="${COMMON_DEPEND}
+ boost? ( >=dev-libs/boost-1.71 )
+"
+BDEPEND="
+ >=dev-util/glib-utils-2.64
+ virtual/pkgconfig
+"
+
+if [[ ${PV} != *9999* ]] ; then
+ BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-aacid )"
+fi
+
+DOCS=( AUTHORS NEWS README.md README-XPDF )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20.12.1-qt5-deps.patch"
+ "${FILESDIR}/${PN}-21.09.0-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.57.0-disable-internal-jpx.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Clang doesn't grok this flag, the configure nicely tests that, but
+ # cmake just uses it, so remove it if we use clang
+ if tc-is-clang ; then
+ sed -e 's/-fno-check-new//' -i cmake/modules/PopplerMacros.cmake || die
+ fi
+
+ if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
+ sed -e '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
+ -i CMakeLists.txt || die
+ else
+ einfo "policy(SET CMP0002 OLD) - workaround can be removed"
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+ local mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT5_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DBUILD_MANUAL_TESTS=OFF
+ -DRUN_GPERF_IF_PRESENT=OFF
+ -DENABLE_BOOST="$(usex boost)"
+ -DENABLE_ZLIB=ON
+ -DENABLE_ZLIB_UNCOMPRESS=OFF
+ -DENABLE_UNSTABLE_API_ABI_HEADERS=ON
+ -DUSE_FLOAT=OFF
+ -DWITH_Cairo=$(usex cairo)
+ -DENABLE_LIBCURL=$(usex curl)
+ -DENABLE_CPP=$(usex cxx)
+ -DWITH_JPEG=$(usex jpeg)
+ -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
+ -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
+ -DENABLE_CMS=$(usex lcms lcms2 none)
+ -DWITH_NSS3=$(usex nss)
+ -DWITH_PNG=$(usex png)
+ $(cmake_use_find_package qt5 Qt5Core)
+ -DWITH_TIFF=$(usex tiff)
+ -DENABLE_UTILS=$(usex utils)
+ -DENABLE_QT6=OFF
+ )
+ use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # live version doesn't provide html documentation
+ if use cairo && use doc && [[ ${PV} != *9999* ]]; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index 5da7405c5289..eafad6c41cf7 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2005-2022 Gentoo Authors
+# Copyright 2005-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -29,13 +29,13 @@ IUSE="boost cairo cjk curl +cxx debug doc +introspection +jpeg +jpeg2k +lcms nss
RESTRICT="test"
COMMON_DEPEND="
- media-libs/fontconfig
- >=media-libs/freetype-2.8
+ >=media-libs/fontconfig-2.13
+ >=media-libs/freetype-2.10
sys-libs/zlib
cairo? (
- dev-libs/glib:2
- x11-libs/cairo
- introspection? ( dev-libs/gobject-introspection:= )
+ >=dev-libs/glib-2.64:2
+ >=x11-libs/cairo-1.16
+ introspection? ( >=dev-libs/gobject-introspection-1.64:= )
)
curl? ( net-misc/curl )
jpeg? ( media-libs/libjpeg-turbo:= )
@@ -54,10 +54,10 @@ RDEPEND="${COMMON_DEPEND}
cjk? ( app-text/poppler-data )
"
DEPEND="${COMMON_DEPEND}
- boost? ( dev-libs/boost )
+ boost? ( >=dev-libs/boost-1.71 )
"
BDEPEND="
- dev-util/glib-utils
+ >=dev-util/glib-utils-2.64
virtual/pkgconfig
"