summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-11-04 13:20:52 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-11-04 13:20:52 -0500
commit25d7b921eeb6a51ac2b0214c5f35ece4ea02fa72 (patch)
tree3baeb7dcce20a5c4a2e338036593612a9f733e3a
parentsci-chemistry/gromacs: Unbundle muParser (diff)
downloadgentoo-25d7b921eeb6a51ac2b0214c5f35ece4ea02fa72.tar.gz
gentoo-25d7b921eeb6a51ac2b0214c5f35ece4ea02fa72.tar.bz2
gentoo-25d7b921eeb6a51ac2b0214c5f35ece4ea02fa72.zip
app-emulation/diskimage-builder: 3.15.0 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.15.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 1d9cf2ad537f..0ff1aa21ff51 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-3.13.0.tar.gz 494027 BLAKE2B 27a88118d688018a5f842e0d483e3128b0715cdc21f33308de61ea5077ad1b824738363ae066463e84e7e3821a36085afc9985fde74883ab040c67a25073e5c0 SHA512 7b099811021f199ed0680e2dc4db6302b05dc6adf95ac96e890501cf92727dc319fbf96f9c68a8b9bca26ba54d7ff5e6a67f036a9d86a3ad1752d5cc4a8edbaf
+DIST diskimage-builder-3.15.0.tar.gz 498998 BLAKE2B 75d0b538eee233d41639fd543e8f91bbe5f39007593e083d9b17b4e8fb77740082acdbaed738b4b1d7fcf360f7ebf0aa38aea341dfd316e9d0dac1dd97cc8f8b SHA512 5dacc6946b0fecc6a49b04b66c46a8ff6021674c1934b16d6698672ece23b698cc1a406c31a41b356969790f8cc7811db67de0246bc654d3341b38ee7f1af617
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.15.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.15.0.ebuild
new file mode 100644
index 000000000000..92726b9c7654
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.15.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"