summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-18 07:41:31 +0100
committerSam James <sam@gentoo.org>2023-04-18 07:50:48 +0100
commit25fad460924d199a4487043199c25a12cfb7d721 (patch)
tree2caf825565705d9f8a3a6c507c83037fcf0116e1
parentdev-cpp/rapidfuzz-cpp: fix build w/ gcc 13 (diff)
downloadgentoo-25fad460.tar.gz
gentoo-25fad460.tar.bz2
gentoo-25fad460.zip
net-misc/netevent: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/895142 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/netevent/files/netevent-2.2.1-gcc13.patch24
-rw-r--r--net-misc/netevent/netevent-2.2.1.ebuild6
2 files changed, 29 insertions, 1 deletions
diff --git a/net-misc/netevent/files/netevent-2.2.1-gcc13.patch b/net-misc/netevent/files/netevent-2.2.1-gcc13.patch
new file mode 100644
index 000000000000..89a7ba359b38
--- /dev/null
+++ b/net-misc/netevent/files/netevent-2.2.1-gcc13.patch
@@ -0,0 +1,24 @@
+https://github.com/Blub/netevent/pull/29
+
+From 85f5db586dac20b69de1345c197e24be6123439d Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 18 Apr 2023 07:40:05 +0100
+Subject: [PATCH] Fix build with GCC 13
+
+GCC 13 (as usual for new compiler releases) shuffles around some internal includes so some
+are no longer transitively included.
+
+See https://gnu.org/software/gcc/gcc-13/porting_to.html.
+
+Bug: https://bugs.gentoo.org/895142
+--- a/src/socket.cpp
++++ b/src/socket.cpp
+@@ -6,6 +6,7 @@
+ * SPDX-License-Identifier: GPL-2.0-or-later
+ */
+ #include "socket.h"
++#include <cstdint>
+ #include <sys/socket.h>
+ #include <sys/un.h>
+
+
diff --git a/net-misc/netevent/netevent-2.2.1.ebuild b/net-misc/netevent/netevent-2.2.1.ebuild
index 139ae8ae9348..01deb12b4c43 100644
--- a/net-misc/netevent/netevent-2.2.1.ebuild
+++ b/net-misc/netevent/netevent-2.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,6 +17,10 @@ BDEPEND="
doc? ( dev-python/docutils )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.1-gcc13.patch
+)
+
src_configure() {
tc-export CXX