summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-06-08 02:19:47 +0200
committerSam James <sam@gentoo.org>2022-06-25 03:50:21 +0100
commit261411be21e0625b89be16ff906e2a2102341406 (patch)
tree7fb466917546eacf430a5bff0abe1aa445ea888e
parentdev-embedded/platformio: add 6.0.2 (diff)
downloadgentoo-261411be.tar.gz
gentoo-261411be.tar.bz2
gentoo-261411be.zip
www-apps/hugo: Increase test timeout
The default test page building timeout is 1 minute, that's a bit too low for slower computers. Closes: https://bugs.gentoo.org/850313 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--www-apps/hugo/files/hugo-0.99.1-test-timeout.patch25
-rw-r--r--www-apps/hugo/hugo-0.99.1.ebuild1
2 files changed, 26 insertions, 0 deletions
diff --git a/www-apps/hugo/files/hugo-0.99.1-test-timeout.patch b/www-apps/hugo/files/hugo-0.99.1-test-timeout.patch
new file mode 100644
index 000000000000..dc0f4898fcf6
--- /dev/null
+++ b/www-apps/hugo/files/hugo-0.99.1-test-timeout.patch
@@ -0,0 +1,25 @@
+From 92ceabab139262750cc6b61ffc3a6341dedfbbd4 Mon Sep 17 00:00:00 2001
+From: tastytea <tastytea@tastytea.de>
+Date: Wed, 8 Jun 2022 04:10:27 +0200
+Subject: [PATCH] Set default test timeout to 2 minutes
+
+Bug: https://bugs.gentoo.org/850313
+---
+ config/configProvider.go | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/config/configProvider.go b/config/configProvider.go
+index 01a2e8c5..c8f199eb 100644
+--- a/config/configProvider.go
++++ b/config/configProvider.go
+@@ -57,6 +57,7 @@ func SetBaseTestDefaults(cfg Provider) Provider {
+ setIfNotSet(cfg, "publishDir", "public")
+ setIfNotSet(cfg, "workingDir", "")
+ setIfNotSet(cfg, "defaultContentLanguage", "en")
++ setIfNotSet(cfg, "timeout", "2m")
+ return cfg
+ }
+
+--
+2.35.1
+
diff --git a/www-apps/hugo/hugo-0.99.1.ebuild b/www-apps/hugo/hugo-0.99.1.ebuild
index 1a189d4c142e..1e707075854f 100644
--- a/www-apps/hugo/hugo-0.99.1.ebuild
+++ b/www-apps/hugo/hugo-0.99.1.ebuild
@@ -40,6 +40,7 @@ PATCHES=(
"${FILESDIR}/${PN}-0.96.0-unbundle-libwebp-and-libsass.patch"
"${FILESDIR}/${PN}-0.96.0-skip-some-tests.patch"
"${FILESDIR}/${PN}-0.99.1-fix-testdecodeconfig-basic.patch"
+ "${FILESDIR}/${PN}-0.99.1-test-timeout.patch"
)
src_configure() {