summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-09 14:54:39 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-09 15:02:30 +0100
commit26185bf7720aa5404298416b8014bc9929731f07 (patch)
treef6ae1abd9b35bdc8adc22a5070243efa8107f43d
parentsys-libs/libsmbios: enable py3.11 (diff)
downloadgentoo-26185bf7.tar.gz
gentoo-26185bf7.tar.bz2
gentoo-26185bf7.zip
sys-libs/libsmbios: add separate Python handling for USE=test
libsmbios actually uses Python in two ways: in installed scripts and in the test suite. Previous incarnations of these ebuilds made the handling of all Python stuff under USE=python but it is entirely possible for someone want to run the test suite without installing all the Python scripts - after all as the name suggests this package IS first and foremost a library. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--sys-libs/libsmbios/libsmbios-2.4.3.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/sys-libs/libsmbios/libsmbios-2.4.3.ebuild b/sys-libs/libsmbios/libsmbios-2.4.3.ebuild
index 0ffef7c562fa..15ae620a9e16 100644
--- a/sys-libs/libsmbios/libsmbios-2.4.3.ebuild
+++ b/sys-libs/libsmbios/libsmbios-2.4.3.ebuild
@@ -14,7 +14,8 @@ LICENSE="|| ( GPL-2+ OSL-2.1 ) BSD Boost-1.0"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~ia64 ~riscv x86"
IUSE="doc graphviz nls +python static-libs test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
@@ -26,8 +27,11 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( app-doc/doxygen )
graphviz? ( media-gfx/graphviz )
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.9.6 )"
+ nls? ( sys-devel/gettext )"
+BDEPEND="test? (
+ ${PYTHON_DEPS}
+ >=dev-util/cppunit-1.9.6
+)"
PATCHES=(
"${FILESDIR}/${PN}-2.2.28-cppunit-tests.patch"
@@ -36,7 +40,9 @@ PATCHES=(
)
pkg_setup() {
- use python && python-single-r1_pkg_setup
+ if use python || use test; then
+ python-single-r1_pkg_setup
+ fi
}
src_prepare() {
@@ -45,7 +51,7 @@ src_prepare() {
# Don't build yum-plugin - we don't need it
sed '/yum-plugin/d' -i Makefile.am || die
- if use test && use python; then
+ if use test; then
python_fix_shebang src/pyunit/test*.py
fi
@@ -69,7 +75,7 @@ src_configure() {
src_install() {
emake install DESTDIR="${D}"
- if use python ; then
+ if use python; then
python_scriptinto /usr/sbin
python_doscript "${ED}"/usr/sbin/smbios-{{battery,keyboard,thermal,token,wakeup,wireless}-ctl,lcd-brightness,passwd,sys-info}
fi