summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2016-06-12 12:29:59 +0900
committerBenda Xu <heroxbd@gentoo.org>2016-06-12 12:30:20 +0900
commit261bb9fd3ee929a2d3db8d7b00b64d4a2e28aea9 (patch)
tree3e75412a5ca4d15388ab2fbddb2f981a34191ff6
parentdev-python/enzyme: add missing PYTHON_REQ_USE (diff)
downloadgentoo-261bb9fd3ee929a2d3db8d7b00b64d4a2e28aea9.tar.gz
gentoo-261bb9fd3ee929a2d3db8d7b00b64d4a2e28aea9.tar.bz2
gentoo-261bb9fd3ee929a2d3db8d7b00b64d4a2e28aea9.zip
dev-python/pygccxml: bump to 1.7.5, update to new HOMEPAGE and SRC_URI.
Package-Manager: portage-2.2.28
-rw-r--r--dev-python/pygccxml/Manifest1
-rw-r--r--dev-python/pygccxml/pygccxml-1.7.5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pygccxml/Manifest b/dev-python/pygccxml/Manifest
index 20dc92a021aa..c6b60690ee0c 100644
--- a/dev-python/pygccxml/Manifest
+++ b/dev-python/pygccxml/Manifest
@@ -1 +1,2 @@
DIST pygccxml-1.0.0.zip 21639068 SHA256 743a83ef67838db45e5d810e647e884272a65fe6cbbbda0f3ed1fdb3aeedb529 SHA512 d2a96b5bb27c3620527839051e43fa1eee8884692707a347c76863ff44a04502dcff35fe18b95a35c32fb8a4935ed8d5d91bf41eb98aee74f6df08c48ddc0b67 WHIRLPOOL 260075fe402c9eb40ee7ba93d0263fccd409020d261842983a9f2b39c00d51f3d3777a85fa0d94a258f52f57c5c2e30c499c258364c1c58cb8ba455b6fe148f0
+DIST pygccxml-1.7.5.tar.gz 3150295 SHA256 a8462c0d74c991534f81405fc52eb05ecd88372f3aff7a49f99bb6c98051a553 SHA512 f76e1748646beaf1b16bd498026e177008f5ebe19e4b35ce612bb27f4f9e6174cdfe4459771adbc657b95e8d5edeea0687756f9ba82cabc10703043c4a7e6e1e WHIRLPOOL a3756918f2933696f8d7bc406d571159c14e2d22dc32debcd7ef569492dd88bc9036efd198ff401f43559be5c148647cac9cf8d7c6a7302249cb65d7015e284e
diff --git a/dev-python/pygccxml/pygccxml-1.7.5.ebuild b/dev-python/pygccxml/pygccxml-1.7.5.ebuild
new file mode 100644
index 000000000000..bfba0a83b2b3
--- /dev/null
+++ b/dev-python/pygccxml/pygccxml-1.7.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generate an XML description of a C++ program from GCC's internal representation"
+HOMEPAGE="https://github.com/gccxml/pygccxml"
+SRC_URI="https://github.com/gccxml/pygccxml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="freedist Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ app-arch/unzip
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-cpp/gccxml-0.6"
+
+python_compile_all() {
+ use doc && emake html man
+}
+
+python_test() {
+ "${PYTHON}" unittests/test_all.py
+}
+
+python_install_all() {
+ if use doc ; then
+ local HTML_DOCS=( docs/_build/html )
+ doman docs/_build/man/${PN}.1
+ fi
+
+ distutils-r1_python_install_all
+}