summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2024-04-26 11:49:20 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-04-29 11:46:46 +0300
commit264373d73ce30e40d423ed8b79b0e1d499628ebc (patch)
tree4f86503040c48ca6b7a81a24f5e17e228b2bbda4
parentgames-emulation/mednafen-jg: drop 1.31.0 (diff)
downloadgentoo-264373d73ce30e40d423ed8b79b0e1d499628ebc.tar.gz
gentoo-264373d73ce30e40d423ed8b79b0e1d499628ebc.tar.bz2
gentoo-264373d73ce30e40d423ed8b79b0e1d499628ebc.zip
www-apps/hugo: add 0.125.4
Signed-off-by: tastytea <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/36403 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/hugo-0.125.4.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index 245cb7ee439a..5b347b9573c2 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -2,3 +2,5 @@ DIST hugo-0.121.2-vendor.tar.xz 6683208 BLAKE2B d4be99aaf686c79cfda28c3ed4d1023b
DIST hugo-0.121.2.tar.gz 21074668 BLAKE2B 06e42bcba49e9e2329ae1b76cc76caf2ac83e13f067533e07cd5471c064ecc402fb7cffaa21df4e20514d96bcfb7f16b4ff078ab23b84506a4ccfc423b21afca SHA512 717da396fa887995e455c1cc7cfc21c535583ba70cb90bcb15ea47e389aa636e9ffa4f66b28bf313f225579e40bc2864ef9da6ebf00d006b3a1ca68f38a47673
DIST hugo-0.124.1-vendor.tar.xz 6740828 BLAKE2B e34cb50eeb22da5f50c8ba7e1318d0f080e6df36f2f1a80e1567d4ccfdd30e4e2ad2153a87c7a18a1d2d6f1e746b5b6c1008d33e41e1900a7e94a42618c5e526 SHA512 2f59a7f2ab199bac5ebf69139b7cc6dd14dc07eab9be39fc39ee5fa41d3332000082407612528d8215a4ebc3a908f28816b19672a28b00bcbad275bea0a9ad35
DIST hugo-0.124.1.tar.gz 21052060 BLAKE2B 41bd17c3aaf1f137de41957dea049b3d7cdaf101d5bfa128e9412b5ea4eee54a0d30481c059b6982c1b803bbe6634643debf1022079320e653dbb37002f7ea35 SHA512 29f51a08f9e757a716c2f7845efc08b1ca3b0bf8e70fd06491735a123ca7da8e169116fa003c147be08d2d5f9752473e9a569085728ec0a9ed7850bd57ba8f93
+DIST hugo-0.125.4-vendor.tar.xz 6722504 BLAKE2B ceccdb09cb41d730e398664f0fae64067e5043f2b63601917f54b8a34b91a761eccca1abe3789287b071948dc971bc97877120e742720384dec8bdcc768a6f6f SHA512 5f2c76478eedadee6a431b17daabc532a0e641c85115900847193ef6be177daa33b3f95023fd0e9c5091e29ed87f406d5c2bc1be69de900fabe8f509496d433e
+DIST hugo-0.125.4.tar.gz 21063288 BLAKE2B 688feac45a0b9c5c7876d28e23b4e1412f4795e866bd1baa06a79f30fe482aea9f7f40a24088c9c252b2528036bd41f3a84c3cb61aa942cf5c56fd9249c000eb SHA512 f76b85e0cb119fa35b8c253ddb05c9f8156aba004b1ec37e0b04d89afa6dec3771417c843594d076c81b1663d0a7677912f9b37ab3ef89ae13824973e6496097
diff --git a/www-apps/hugo/hugo-0.125.4.ebuild b/www-apps/hugo/hugo-0.125.4.ebuild
new file mode 100644
index 000000000000..93b9e87528d4
--- /dev/null
+++ b/www-apps/hugo/hugo-0.125.4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module shell-completion
+
+DESCRIPTION="Fast static HTML and CSS website generator"
+HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
+SRC_URI="
+ https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
+"
+
+# NOTE: To create the vendor tarball, run:
+# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="doc +extended test"
+
+BDEPEND="
+ >=dev-lang/go-1.22.2
+ test? (
+ dev-python/docutils
+ dev-ruby/asciidoctor
+ virtual/pandoc
+ )
+"
+RDEPEND="
+ extended? (
+ dev-libs/libsass:=
+ >=media-libs/libwebp-1.3.2:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.121.0-unbundle-libwebp-and-libsass.patch
+ "${FILESDIR}"/${PN}-0.123.0-skip-some-tests.patch
+)
+
+src_configure() {
+ export CGO_ENABLED=1
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export MY_BUILD_FLAGS="$(usev extended "-tags extended")"
+
+ default
+}
+
+src_prepare() {
+ # wants to run command that require network access
+ rm testscripts/commands/mod{,_vendor,__disable,_get,_get_u,_npm{,_withexisting}}.txt || die
+
+ default
+}
+
+src_compile() {
+ mkdir -pv bin || die
+ ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
+ ${MY_BUILD_FLAGS} -o "${S}/bin/hugo"
+
+ bin/hugo gen man --dir man || die
+
+ mkdir -pv completions || die
+ bin/hugo completion bash > completions/hugo || die
+ bin/hugo completion fish > completions/hugo.fish || die
+ bin/hugo completion zsh > completions/_hugo || die
+
+ if use doc ; then
+ bin/hugo gen doc --dir doc || die
+ fi
+}
+
+src_test() {
+ ego test "./..." ${MY_BUILD_FLAGS}
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+
+ dobashcomp completions/${PN}
+ dofishcomp completions/${PN}.fish
+ dozshcomp completions/_${PN}
+
+ if use doc ; then
+ dodoc -r doc/*
+ fi
+}
+
+pkg_postinst() {
+ elog "the sass USE-flag was renamed to extended. the functionality is the" \
+ "same, except it also toggles the dependency on libwebp (for encoding)"
+}