summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-05-01 20:30:23 +0200
committerSebastian Pipping <sping@gentoo.org>2024-05-01 20:31:42 +0200
commit264486eee1dc8f58f7d2d892cd8a3bcb8f877fd9 (patch)
tree8b03ba78656482066dad6071ffebb097443099fd
parentdev-python/tavern: Remove old (diff)
downloadgentoo-264486eee1dc8f58f7d2d892cd8a3bcb8f877fd9.tar.gz
gentoo-264486eee1dc8f58f7d2d892cd8a3bcb8f877fd9.tar.bz2
gentoo-264486eee1dc8f58f7d2d892cd8a3bcb8f877fd9.zip
sys-apps/dcfldd: Add missing build dependency virtual/pkgconfig
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
-rw-r--r--sys-apps/dcfldd/dcfldd-1.9.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/dcfldd/dcfldd-1.9.1-r1.ebuild b/sys-apps/dcfldd/dcfldd-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..cdb9568c5856
--- /dev/null
+++ b/sys-apps/dcfldd/dcfldd-1.9.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools bash-completion-r1
+
+DESCRIPTION="enhanced dd with features for forensics and security"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/dcfldd"
+SRC_URI="https://github.com/resurrecting-open-source-projects/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+
+DEPEND="virtual/pkgconfig"
+
+DOCS=(
+ AUTHORS
+ CONTRIBUTING.md
+ ChangeLog
+ NEWS
+ README.md
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ newbashcomp doc/dcfldd-bash_completion dcfldd
+}