summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-03 23:04:25 +0000
committerSam James <sam@gentoo.org>2021-04-03 23:07:21 +0000
commit26701d265987756275119d98eb0718259b6699ae (patch)
treee90b9f08ed726e864233744f54e57e692f541b32
parentapp-misc/getopt: eutils-- (diff)
downloadgentoo-26701d265987756275119d98eb0718259b6699ae.tar.gz
gentoo-26701d265987756275119d98eb0718259b6699ae.tar.bz2
gentoo-26701d265987756275119d98eb0718259b6699ae.zip
app-misc/jail: eutils--, fix ${D} in src_compile
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/jail/jail-2.0-r4.ebuild55
-rw-r--r--app-misc/jail/metadata.xml8
2 files changed, 33 insertions, 30 deletions
diff --git a/app-misc/jail/jail-2.0-r4.ebuild b/app-misc/jail/jail-2.0-r4.ebuild
index 4e8ef915d7e0..b3921ab2daec 100644
--- a/app-misc/jail/jail-2.0-r4.ebuild
+++ b/app-misc/jail/jail-2.0-r4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils flag-o-matic toolchain-funcs
+
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Builds a chroot and configures all the required files, directories and libraries"
HOMEPAGE="https://github.com/spiculator/jail"
@@ -11,13 +12,11 @@ SRC_URI="https://github.com/spiculator/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 x86"
-IUSE=""
RDEPEND="
dev-lang/perl
dev-util/strace
"
-DEPEND=""
PATCHES=(
"${FILESDIR}"/${PN}-1.9-gentoo.patch
@@ -35,41 +34,45 @@ PATCHES=(
)
src_compile() {
+ emake -C src CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
# configuration files should be installed in /etc not /usr/etc
sed -i "s:\$4/etc:\${D}/etc:g" install.sh || die
# the destination directory should be /usr not /usr/local
- sed -i -e "s:usr/local:${D}/usr:g" \
- -e "s:^COPT =.*:COPT = -Wl,-z,no:g" src/Makefile || die
+ sed -i \
+ -e "s:usr/local:${D}/usr:g" \
+ -e "s:^COPT =.*:COPT = -Wl,-z,no:g" \
+ src/Makefile || die
- emake -C src CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
-}
-
-src_install() {
emake -C src install
# remove //var/tmp/portage/${P}/image//usr from files
- FILES=( "${D}/usr/bin/mkjailenv"
- "${D}/usr/bin/addjailsw"
- "${D}/usr/bin/addjailuser"
- "${D}/etc/jail.conf"
- "${D}/usr/lib/libjail.pm"
- "${D}/usr/lib/arch/generic/definitions"
- "${D}/usr/lib/arch/generic/functions"
- "${D}/usr/lib/arch/linux/definitions"
- "${D}/usr/lib/arch/linux/functions"
- "${D}/usr/lib/arch/freebsd/definitions"
- "${D}/usr/lib/arch/freebsd/functions"
- "${D}/usr/lib/arch/irix/definitions"
- "${D}/usr/lib/arch/irix/functions"
- "${D}/usr/lib/arch/solaris/definitions"
- "${D}/usr/lib/arch/solaris/functions" )
+ FILES=(
+ "${ED}/usr/bin/mkjailenv"
+ "${ED}/usr/bin/addjailsw"
+ "${ED}/usr/bin/addjailuser"
+ "${ED}/etc/jail.conf"
+ "${ED}/usr/lib/libjail.pm"
+ "${ED}/usr/lib/arch/generic/definitions"
+ "${ED}/usr/lib/arch/generic/functions"
+ "${ED}/usr/lib/arch/linux/definitions"
+ "${ED}/usr/lib/arch/linux/functions"
+ "${ED}/usr/lib/arch/freebsd/definitions"
+ "${ED}/usr/lib/arch/freebsd/functions"
+ "${ED}/usr/lib/arch/irix/definitions"
+ "${ED}/usr/lib/arch/irix/functions"
+ "${ED}/usr/lib/arch/solaris/definitions"
+ "${ED}/usr/lib/arch/solaris/functions"
+ )
for f in "${FILES[@]}"; do
sed -i "s:/${D}/usr:/usr:g" ${f} || die
done
- sed -i "s:/usr/etc:/etc:" "${D}"/usr/lib/libjail.pm || die
+ sed -i "s:/usr/etc:/etc:" "${ED}"/usr/lib/libjail.pm || die
dodoc doc/{CHANGELOG,INSTALL,README,SECURITY,VERSION}
}
diff --git a/app-misc/jail/metadata.xml b/app-misc/jail/metadata.xml
index 425dd3d2d460..26ee509dcdca 100644
--- a/app-misc/jail/metadata.xml
+++ b/app-misc/jail/metadata.xml
@@ -7,9 +7,9 @@
<bugs-to>https://github.com/spiculator/jail/issues</bugs-to>
</upstream>
<longdescription>
-Jail Chroot Project is an attempt of write a tool that builds a chrooted environment.
-The main goal of Jail is to be as simple as possible, and highly portable. The most
-difficult step when building a chrooted environment is to set up the right libraries and
-files. Here, Jail comes to the rescue with a tool to automagically configures and builds
+Jail Chroot Project is an attempt of write a tool that builds a chrooted environment.
+The main goal of Jail is to be as simple as possible, and highly portable. The most
+difficult step when building a chrooted environment is to set up the right libraries and
+files. Here, Jail comes to the rescue with a tool to automagically configures and builds
all the required files, directories and libraries.</longdescription>
</pkgmetadata>