summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-10-01 08:36:22 +0200
committerHans de Graaff <graaff@gentoo.org>2017-10-01 08:44:39 +0200
commit268eb4a609d0438db8d9fbadac231b8b0ee5ffed (patch)
treebd0f3dad2ee1e18db1107762ca9d6d2ab1d5ae6f
parentdev-python/wsgiproxy2: Bump (diff)
downloadgentoo-268eb4a6.tar.gz
gentoo-268eb4a6.tar.bz2
gentoo-268eb4a6.zip
dev-ruby/httpclient: skip failing tests, bug 632454
Package-Manager: Portage-2.3.8, Repoman-2.3.2
-rw-r--r--dev-ruby/httpclient/httpclient-2.8.3.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-ruby/httpclient/httpclient-2.8.3.ebuild b/dev-ruby/httpclient/httpclient-2.8.3.ebuild
index 62b42a2abb1d..31d579ef823e 100644
--- a/dev-ruby/httpclient/httpclient-2.8.3.ebuild
+++ b/dev-ruby/httpclient/httpclient-2.8.3.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+USE_RUBY="ruby22 ruby23 ruby24"
RUBY_FAKEGEM_TASK_TEST="-Ilib test"
RUBY_FAKEGEM_TASK_DOC="doc"
@@ -54,6 +54,12 @@ all_ruby_prepare() {
# Skip tests using rack-ntlm which is not packaged. Weirdly these
# only fail on jruby.
rm test/test_auth.rb || die
+
+ # Skip test failing due to hard-coded expired certificate
+ sed -i -e '/test_verification_without_httpclient/,/^ end/ s:^:#:' test/test_ssl.rb || die
+
+ # Skip test depending on obsolete and vulnerable SSLv3
+ sed -i -e '/test_no_sslv3/,/^ end/ s:^:#:' test/test_ssl.rb || die
}
each_ruby_test() {