summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-02-20 15:58:04 +0100
committerYixun Lan <dlan@gentoo.org>2024-02-22 01:10:32 +0000
commit268fb9bf508aae57a6f62178d372ef2094ab7ff5 (patch)
treee72e55feabef24e2eb263b3d9fe20dc2af06464e
parentdev-lang/go: Stabilize 1.21.7 arm, #925200 (diff)
downloadgentoo-268fb9bf508aae57a6f62178d372ef2094ab7ff5.tar.gz
gentoo-268fb9bf508aae57a6f62178d372ef2094ab7ff5.tar.bz2
gentoo-268fb9bf508aae57a6f62178d372ef2094ab7ff5.zip
gui-apps/wmenu: import from ::guru, add 0.1.6
Will be used in sway-1.9 default configuration[1] so should be in ::gentoo, has been in ::guru since 2023-07-02. [1]: https://github.com/swaywm/sway/pull/7384 Closes: https://github.com/gentoo/gentoo/pull/35440 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--gui-apps/wmenu/Manifest1
-rw-r--r--gui-apps/wmenu/metadata.xml15
-rw-r--r--gui-apps/wmenu/wmenu-0.1.6.ebuild28
3 files changed, 44 insertions, 0 deletions
diff --git a/gui-apps/wmenu/Manifest b/gui-apps/wmenu/Manifest
new file mode 100644
index 000000000000..898b17be80eb
--- /dev/null
+++ b/gui-apps/wmenu/Manifest
@@ -0,0 +1 @@
+DIST wmenu-0.1.6.tar.gz 17447 BLAKE2B f624773e29c751cb0d890d428482019bab35af1d3f540a53233307d30955dd5936a3eab483be7dac471aab6a85a4cd1953d9a75f095130316a13f96684d52477 SHA512 d3b802c0bab2ee5ffbbf9b0bf0708cff842346cc88e5b005090fd1a891e2e8e3f2d0aa8e2fd9b4d661d9a0ce7797f7142ca38afdee9ae1e86098a50dcd25b30a
diff --git a/gui-apps/wmenu/metadata.xml b/gui-apps/wmenu/metadata.xml
new file mode 100644
index 000000000000..dab273aa5a95
--- /dev/null
+++ b/gui-apps/wmenu/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>contact@hacktivis.me</email>
+ <name>Haelwenn (lanodan) Monnier</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourcehut">~adnano/wmenu</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/wmenu/wmenu-0.1.6.ebuild b/gui-apps/wmenu/wmenu-0.1.6.ebuild
new file mode 100644
index 000000000000..53ce05aa63f7
--- /dev/null
+++ b/gui-apps/wmenu/wmenu-0.1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="dynamic menu for wlroots compositors, maintains the look and feel of dmenu"
+HOMEPAGE="https://sr.ht/~adnano/wmenu/"
+SRC_URI="https://git.sr.ht/~adnano/wmenu/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ app-text/scdoc
+ dev-util/wayland-scanner
+"
+RDEPEND="
+ x11-libs/cairo
+ x11-libs/pango
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"