summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-30 08:02:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-30 08:10:01 +0100
commit2695ec96e9e8465c5365ab5f03156c3be4d7fc21 (patch)
tree7280591bde8de5330768814d2bdb623769133aad
parentdev-python/flask-migrate: Bump to 4.0.3 (diff)
downloadgentoo-2695ec96.tar.gz
gentoo-2695ec96.tar.bz2
gentoo-2695ec96.zip
dev-python/humanize: Bump to 4.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-4.5.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 92ad9dc9970b..9ecfd1055dd0 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1 +1,2 @@
DIST humanize-4.4.0.tar.gz 78519 BLAKE2B f61b654e201995479ace22b5aac106b08304ed9212cf5c6c7f87731d861c42c5e0243f7bb0b7f2c29b870421fa81fba0c36e4ead90ff90f207bc984286ac119a SHA512 bbbd386d9af82d9db0f2edc4653928654203c4239419232abfc15c51ccd865b355366549c46651e1291d4222ca8b2a297ffc0fce3cc32be4ae2f904ae308a8e4
+DIST humanize-4.5.0.tar.gz 82709 BLAKE2B 97173e7b3dc7b35ff8dbb5b985153c35dd49332d733464ece7eeb00a23c2f7f2660fde9263b416dcd83f11e8ec0a578a4fa1648c6955b8dbc35540a2606d0d38 SHA512 7f045f6cf7c6c5cd37ecd1a3d5c6ed40d3e64e14d0718b07938c01ce3722e0487cbc90752840b644b8befff5c7db16090d510eabeb59c4dcf5306eadea005019
diff --git a/dev-python/humanize/humanize-4.5.0.ebuild b/dev-python/humanize/humanize-4.5.0.ebuild
new file mode 100644
index 000000000000..79adf26cf1e9
--- /dev/null
+++ b/dev-python/humanize/humanize-4.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="
+ https://github.com/python-humanize/humanize/
+ https://pypi.org/project/humanize/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >=dev-python/setuptools_scm-6.2[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest