summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matt@offtopica.uk>2022-01-02 13:41:02 +0000
committerFlorian Schmaus <flow@gentoo.org>2022-01-02 15:25:19 +0100
commit26995178f18790dc02743b94a944306ee5e8f51d (patch)
treeda6d98b2a2c5b05a0af26488f379ec6c5b52260d
parentdev-ada/ada_libfswatch: fix S (diff)
downloadgentoo-26995178f18790dc02743b94a944306ee5e8f51d.tar.gz
gentoo-26995178f18790dc02743b94a944306ee5e8f51d.tar.bz2
gentoo-26995178f18790dc02743b94a944306ee5e8f51d.zip
dev-util/rebar-bin: add 3.18.0
Signed-off-by: Matthew Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/23630 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-util/rebar-bin/Manifest1
-rw-r--r--dev-util/rebar-bin/rebar-bin-3.18.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/rebar-bin/Manifest b/dev-util/rebar-bin/Manifest
index f2b2fac01ae6..dba647f92b20 100644
--- a/dev-util/rebar-bin/Manifest
+++ b/dev-util/rebar-bin/Manifest
@@ -1,2 +1,3 @@
DIST rebar-bin-3.16.1 942316 BLAKE2B c3296d54f85c146a58ff24a9b337f7d26e2beb3287257ecca6344c082b84295d9daf042b7bcb422df7c5dd29dd681f0c81064c1ef5b7b30ed8be8328ca694bc4 SHA512 be9e4ffdf654f8038ff14cd4b53328bdbc8b26e0f1306a16220f4d5d4b13bc36ac2f302d52a799424ffc3835e41ce326a4fd8e422ececf70ab8c0f951e3e4b24
DIST rebar-bin-3.17.0 944741 BLAKE2B 2ae670b36019afcc6e595bcbb7d9db7286bd0ea44ad095e7bd0b45be579f6b45d0cc4bbb11478e13adbeb68231f3a888ff231ca4ee4881cb30a26dd68eb8b60e SHA512 908ed9018e456cb4a8f6c9b2737ead58f632bbcac4960834de841b814a97f8fac2181b8630e2ae9e8e9680c4965488b2a736c54baa561a089489987615f6405e
+DIST rebar-bin-3.18.0 952478 BLAKE2B 3719582dd2328bcc63b328bb177de14702d517049e0935fe25def30c1b290efa64b891711cb6616152904b48ad4dade9623fd50d81b7f850c118156991bacb43 SHA512 f52b79f3e1527687ddddc50062eb0a520e913f8a381b9eb836886988460f2e38f135d03e1ecf1022f332498116a498619b3d1f71663bb51d9af9cd7a5c4efc0a
diff --git a/dev-util/rebar-bin/rebar-bin-3.18.0.ebuild b/dev-util/rebar-bin/rebar-bin-3.18.0.ebuild
new file mode 100644
index 000000000000..12502e7a00eb
--- /dev/null
+++ b/dev-util/rebar-bin/rebar-bin-3.18.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://rebar3.org https://github.com/erlang/rebar3"
+SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3 -> ${P}"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/erlang"
+
+QA_PREBUILT="usr/bin/rebar3"
+
+src_install() {
+ newbin "${DISTDIR}"/${P} rebar3
+}