summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-09-18 11:46:48 -0400
committerTim Harder <radhermit@gentoo.org>2016-09-18 11:50:51 -0400
commit26b92fb5a2b012154406d7ad585752ceb341363a (patch)
treedbc3fb2cb635f44a2d5d01d8573fccd07411f146
parentapp-misc/evemu: remove old (diff)
downloadgentoo-26b92fb5a2b012154406d7ad585752ceb341363a.tar.gz
gentoo-26b92fb5a2b012154406d7ad585752ceb341363a.tar.bz2
gentoo-26b92fb5a2b012154406d7ad585752ceb341363a.zip
dev-python/cffi: version bump to 1.8.3
-rw-r--r--dev-python/cffi/Manifest1
-rw-r--r--dev-python/cffi/cffi-1.8.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/cffi/Manifest b/dev-python/cffi/Manifest
index 3e85f9765139..fbf672b0d8b0 100644
--- a/dev-python/cffi/Manifest
+++ b/dev-python/cffi/Manifest
@@ -3,3 +3,4 @@ DIST cffi-1.5.2.tar.gz 388793 SHA256 da9bde99872e46f7bb5cff40a9b1cc08406765efafb
DIST cffi-1.6.0.tar.gz 397024 SHA256 a7f75c4ef2362c0a0e54657add0a6c509fecbfa3b3807bc0925f5cb1c9f927db SHA512 95dc7fbca624b5474ff0182ff6e1d1c6b8b34ad19c4c22cabf847f7be6c47dc32a96b23165da1c28438a46a1e9f681341fe8b7304ba5618744c595c4ae364466 WHIRLPOOL a4faef6dfaa078a09abadbe2af6d589dcd36d94bcf07eb47cda1e18ae1d60a3d62d0d66240f717f09564b97565b495e71b77390fe4278afb978fa2c62d341684
DIST cffi-1.7.0.tar.gz 400251 SHA256 6ed5dd6afd8361f34819c68aaebf9e8fc12b5a5893f91f50c9e50c8886bb60df SHA512 ce9439a219248b06a6f2d019324f4150576b5e4d853025d61d470105f95af2a6c2387080bfd0308c063ad756f34feead9a5958187d626524594dfe9a3adf7462 WHIRLPOOL 1d10ba1d5fe2dadfe239c2111e9eb08beeddb7b796e966dae642fbfef0d590737018e27e3036817a1b2f43d76d2526642022b0d2ebe97ce8fcf4a49c8006ea26
DIST cffi-1.8.2.tar.gz 403191 SHA256 2b636db1a179439d73ae0a090479e179a43df5d4eddc7e4c4067f960d4038530 SHA512 a7bbb8735cf4b36510b6953db26af2428725d589fedae05693f39c77b84567bdefd6e3dc1e5c6deef94e617ceb4bf6bf92379e76fd3732d73a19e8a39a3d06ed WHIRLPOOL 5442e4c5ab58fad20b05cc545721417e73992ef3584dc24501124075647d667a640230ff3a67e362c376aa32aff0c7d93b17425682f132532e2c165cd954b3dc
+DIST cffi-1.8.3.tar.gz 403766 SHA256 c321bd46faa7847261b89c0469569530cad5a41976bb6dba8202c0159f476568 SHA512 a5a5f62c9d8607a8477abc2c2c53dcbe2aa4cf964b0592d4db349cd35a199e69a84d6cf160973fb5ee736607fa6a41314e8ff0d84bef2ffe16c08f6071c15222 WHIRLPOOL 9ab2f3bf534f4c7b925f3617a109c31ed6591500c551e0c1cae2443b506fa5aea8a1b91b9c378646354effba3d12f0002727be0560359ed40eb3c8751a352c03
diff --git a/dev-python/cffi/cffi-1.8.3.ebuild b/dev-python/cffi/cffi-1.8.3.ebuild
new file mode 100644
index 000000000000..640db6d03477
--- /dev/null
+++ b/dev-python/cffi/cffi-1.8.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# DO NOT ADD pypy to PYTHON_COMPAT
+# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code"
+HOMEPAGE="http://cffi.readthedocs.org/ https://pypi.python.org/pypi/cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc test"
+
+RDEPEND="
+ virtual/libffi
+ dev-python/pycparser[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ einfo "$PYTHONPATH"
+ $PYTHON -c "import _cffi_backend as backend" || die
+ PYTHONPATH="${PYTHONPATH}" \
+ py.test -x -v \
+ --ignore testing/test_zintegration.py \
+ --ignore testing/embedding \
+ c/ testing/ \
+ || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}