summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-11-16 22:45:51 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-16 22:45:51 +0100
commit26bb54471ac2c096fef160d3eb68fbb3fd0eb9b6 (patch)
treee282c2fde0ad18684777b0557282228e31ee6644
parentdev-lang/python: Stabilize 3.8.6 amd64, #754786 (diff)
downloadgentoo-26bb54471ac2c096fef160d3eb68fbb3fd0eb9b6.tar.gz
gentoo-26bb54471ac2c096fef160d3eb68fbb3fd0eb9b6.tar.bz2
gentoo-26bb54471ac2c096fef160d3eb68fbb3fd0eb9b6.zip
games-fps/nexuiz: correctly pass flags and compiler
Closes: https://bugs.gentoo.org/739288 Closes: https://bugs.gentoo.org/710826 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild b/games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild
index 2778fcff0c04..e23daea87d60 100644
--- a/games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild
+++ b/games-fps/nexuiz/nexuiz-2.5.2-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils
+inherit eutils toolchain-funcs
MY_PN=Nexuiz
MY_P=${PN}-${PV//./}
@@ -69,9 +69,8 @@ src_prepare() {
# Make the game automatically look in the correct data directory
sed -i \
- -e "/^CC=/d" \
- -e "s:-O2:${CFLAGS}:" \
- -e "/-lm/s:$: ${LDFLAGS}:" \
+ -e 's:-O2:$(CFLAGS):' \
+ -e '/-lm/s:$: $(LDFLAGS):' \
-e '/^STRIP/s/strip/true/' \
makefile.inc || die
@@ -88,6 +87,7 @@ src_prepare() {
}
src_compile() {
+ tc-export CC
if use opengl || ! use dedicated ; then
emake cl-${PN}
if use sdl ; then