summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-12-04 15:41:16 +0100
committerPacho Ramos <pacho@gentoo.org>2022-12-04 15:49:22 +0100
commit26c9331be2f01733984f7f46720bd517772df369 (patch)
tree1f7c1c7ea3fe5760c4a60506c00a8daf63de0b6e
parentnet-libs/libnma: Fix crash when trying to configure EAP using profiles (diff)
downloadgentoo-26c9331b.tar.gz
gentoo-26c9331b.tar.bz2
gentoo-26c9331b.zip
x11-misc/xdg-utils: Don't use egrep
Closes: https://bugs.gentoo.org/883589 Thanks-to: Hanno Böck Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--x11-misc/xdg-utils/files/xdg-utils-egrep.patch25
-rw-r--r--x11-misc/xdg-utils/xdg-utils-1.1.3_p20210805-r1.ebuild87
2 files changed, 112 insertions, 0 deletions
diff --git a/x11-misc/xdg-utils/files/xdg-utils-egrep.patch b/x11-misc/xdg-utils/files/xdg-utils-egrep.patch
new file mode 100644
index 000000000000..71608552a08b
--- /dev/null
+++ b/x11-misc/xdg-utils/files/xdg-utils-egrep.patch
@@ -0,0 +1,25 @@
+From 7538458c6c8999296a272c40bd4ec24132a51877 Mon Sep 17 00:00:00 2001
+From: E5ten <ethancsommer@gmail.com>
+Date: Thu, 16 Jan 2020 02:06:09 +0000
+Subject: [PATCH] switch from non-standard "egrep" to POSIX "grep -E"
+
+---
+ scripts/xdg-open.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/scripts/xdg-open.in b/scripts/xdg-open.in
+index 202f3e3..35b0522 100644
+--- a/scripts/xdg-open.in
++++ b/scripts/xdg-open.in
+@@ -72,7 +72,7 @@ get_key()
+ is_file_url_or_path()
+ {
+ if echo "$1" | grep -q '^file://' \
+- || ! echo "$1" | egrep -q '^[[:alpha:]][[:alpha:][:digit:]+\.\-]*:'; then
++ || ! echo "$1" | grep -Eq '^[[:alpha:]][[:alpha:][:digit:]+\.\-]*:'; then
+ return 0
+ else
+ return 1
+--
+GitLab
+
diff --git a/x11-misc/xdg-utils/xdg-utils-1.1.3_p20210805-r1.ebuild b/x11-misc/xdg-utils/xdg-utils-1.1.3_p20210805-r1.ebuild
new file mode 100644
index 000000000000..7aec38025c3e
--- /dev/null
+++ b/x11-misc/xdg-utils/xdg-utils-1.1.3_p20210805-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_COMMIT="1a58bc28f6844898532daf9ee1bf6da7764955a9"
+DESCRIPTION="Portland utils for cross-platform/cross-toolkit/cross-desktop interoperability"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/xdg-utils/"
+SRC_URI="https://gitlab.freedesktop.org/xdg/xdg-utils/-/archive/${MY_COMMIT}/${P}.tar.bz2"
+# https://gitlab.freedesktop.org/xdg/xdg-utils/-/merge_requests/24
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-1.1.3_p20200220-no-which.patch.xz"
+S="${WORKDIR}"/xdg-utils-${MY_COMMIT}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="dbus doc gnome"
+REQUIRED_USE="gnome? ( dbus )"
+
+RDEPEND="
+ dev-util/desktop-file-utils
+ dev-perl/File-MimeInfo
+ dbus? (
+ sys-apps/dbus
+ gnome? (
+ dev-perl/Net-DBus
+ dev-perl/X11-Protocol
+ )
+ )
+ x11-misc/shared-mime-info
+ x11-apps/xprop
+ x11-apps/xset
+"
+BDEPEND="
+ >=app-text/xmlto-0.0.28-r3[text(+)]
+ app-alternatives/awk
+"
+
+DOCS=( ChangeLog README RELEASE_NOTES TODO )
+
+# Tests run random system programs, including interactive programs
+# that block forever
+RESTRICT="test"
+
+PATCHES=(
+ "${WORKDIR}"/${PN}-1.1.3_p20200220-no-which.patch
+ # https://gitlab.freedesktop.org/xdg/xdg-utils/-/merge_requests/21
+ "${FILESDIR}"/${PN}-egrep.patch
+)
+
+src_prepare() {
+ default
+
+ # If you choose to do git snapshot instead of patchset, you need to remember
+ # to run `autoconf` in ./ and `make scripts-clean` in ./scripts/ to refresh
+ # all the files
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_path_XMLTO="$(type -P xmlto) --skip-validation" #502166
+ default
+ emake -C scripts scripts-clean
+}
+
+src_install() {
+ default
+
+ newdoc scripts/xsl/README README.xsl
+ use doc && dodoc -r scripts/html
+
+ # Install default XDG_DATA_DIRS, bug #264647
+ echo XDG_DATA_DIRS=\"${EPREFIX}/usr/local/share\" > 30xdg-data-local
+ echo 'COLON_SEPARATED="XDG_DATA_DIRS XDG_CONFIG_DIRS"' >> 30xdg-data-local
+ doenvd 30xdg-data-local
+
+ echo XDG_DATA_DIRS=\"${EPREFIX}/usr/share\" > 90xdg-data-base
+ echo XDG_CONFIG_DIRS=\"${EPREFIX}/etc/xdg\" >> 90xdg-data-base
+ doenvd 90xdg-data-base
+}
+
+pkg_postinst() {
+ [[ -x $(type -P gtk-update-icon-cache) ]] \
+ || elog "Install dev-util/gtk-update-icon-cache for the gtk-update-icon-cache command."
+}