summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-04-10 17:53:04 -0700
committerJason Zaman <perfinion@gentoo.org>2022-04-10 20:43:53 -0700
commit26cc733271f74892bd6dc93de32df3ee23440fb0 (patch)
tree3ad014031e4d4c78629c308bf217ded1e85f4051
parentsys-apps/mcstrans: update live ebuild (diff)
downloadgentoo-26cc7332.tar.gz
gentoo-26cc7332.tar.bz2
gentoo-26cc7332.zip
sys-apps/restorecond: update live ebuild
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
-rw-r--r--sys-apps/restorecond/restorecond-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/sys-apps/restorecond/restorecond-9999.ebuild b/sys-apps/restorecond/restorecond-9999.ebuild
index f3e66897e8c1..92cd1c69200e 100644
--- a/sys-apps/restorecond/restorecond-9999.ebuild
+++ b/sys-apps/restorecond/restorecond-9999.ebuild
@@ -1,19 +1,21 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
inherit systemd toolchain-funcs
-IUSE=""
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
S="${WORKDIR}/${P}/${PN}"
else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
fi
DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
@@ -21,6 +23,7 @@ HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
LICENSE="GPL-2"
SLOT="0"
+IUSE=""
DEPEND="dev-libs/glib:2
>=sys-libs/libsepol-${PV}:=
@@ -40,9 +43,10 @@ src_compile() {
}
src_install() {
- SYSTEMDSYSTEMUNITDIR="$(systemd_get_systemunitdir)" \
+ emake DESTDIR="${D}" \
+ SYSTEMDSYSTEMUNITDIR="$(systemd_get_systemunitdir)" \
SYSTEMDUSERUNITDIR=$(systemd_get_userunitdir) \
- emake DESTDIR="${D}" install
+ install
rm -rf "${D}/etc/rc.d" || die