summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-29 11:01:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-29 11:08:51 +0100
commit26d1b1c744d967ff7b6645ba473f6e12ff87d9d5 (patch)
tree553914d6b822c01607d3a59325fb10c21d548a85
parentdev-util/cmake: Bump to version 3.13.1 (diff)
downloadgentoo-26d1b1c7.tar.gz
gentoo-26d1b1c7.tar.bz2
gentoo-26d1b1c7.zip
kde-plasma/plasma-desktop: Fix taskbar crash on grouped windows
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.14.4-taskbar-crash.patch39
-rw-r--r--kde-plasma/plasma-desktop/plasma-desktop-5.14.4-r1.ebuild146
2 files changed, 185 insertions, 0 deletions
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.14.4-taskbar-crash.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.14.4-taskbar-crash.patch
new file mode 100644
index 000000000000..1a0a8957ef07
--- /dev/null
+++ b/kde-plasma/plasma-desktop/files/plasma-desktop-5.14.4-taskbar-crash.patch
@@ -0,0 +1,39 @@
+From ed34cc5f181e61d1fc98872866c5d7300a90af86 Mon Sep 17 00:00:00 2001
+From: Eike Hein <hein@kde.org>
+Date: Thu, 29 Nov 2018 00:22:17 +0900
+Subject: [PATCH] Fix group popup dialog
+
+Summary:
+Fixes regression introduced with ab26ebb18b74: That diff contained
+a change unrelated to the original submission, swapping a || out for
+&& in response to a review note. This turns out to have broken things.
+
+BUG:401508
+
+Reviewers: davidedmundson
+
+Subscribers: plasma-devel
+
+Tags: #plasma
+
+Differential Revision: https://phabricator.kde.org/D17219
+---
+ applets/taskmanager/package/contents/ui/GroupDialog.qml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/applets/taskmanager/package/contents/ui/GroupDialog.qml b/applets/taskmanager/package/contents/ui/GroupDialog.qml
+index 6f592756..28238dce 100644
+--- a/applets/taskmanager/package/contents/ui/GroupDialog.qml
++++ b/applets/taskmanager/package/contents/ui/GroupDialog.qml
+@@ -262,7 +262,7 @@ PlasmaCore.Dialog {
+ // Setting VisualDataModel.rootIndex drops groupRepeater.count to 0
+ // before the actual row count. updateSize is therefore invoked twice;
+ // only update size once the repeater count matches the model role.
+- } else if (!groupRepeater.aboutToPopulate && visualParent.childCount == groupRepeater.count) {
++ } else if (!groupRepeater.aboutToPopulate || visualParent.childCount == groupRepeater.count) {
+ var task;
+ var maxWidth = 0;
+ var maxHeight = 0;
+--
+2.19.2
+
diff --git a/kde-plasma/plasma-desktop/plasma-desktop-5.14.4-r1.ebuild b/kde-plasma/plasma-desktop/plasma-desktop-5.14.4-r1.ebuild
new file mode 100644
index 000000000000..c8d04a38a96a
--- /dev/null
+++ b/kde-plasma/plasma-desktop/plasma-desktop-5.14.4-r1.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Plasma desktop"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="appstream +fontconfig ibus +mouse scim +semantic-desktop touchpad"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep attica)
+ $(add_frameworks_dep kactivities)
+ $(add_frameworks_dep kactivities-stats)
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kded)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpeople)
+ $(add_frameworks_dep krunner)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_frameworks_dep sonnet)
+ $(add_plasma_dep kwin)
+ $(add_plasma_dep plasma-workspace)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5(+)]
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxcb
+ x11-libs/libxkbfile
+ appstream? ( >=dev-libs/appstream-0.12.2[qt5] )
+ fontconfig? (
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/libXft
+ x11-libs/xcb-util-image
+ )
+ ibus? (
+ $(add_qt_dep qtx11extras)
+ app-i18n/ibus
+ dev-libs/glib:2
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ )
+ scim? ( app-i18n/scim )
+ semantic-desktop? ( $(add_frameworks_dep baloo) )
+ touchpad? ( x11-drivers/xf86-input-synaptics )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ x11-base/xorg-proto
+ fontconfig? ( x11-libs/libXrender )
+ mouse? (
+ x11-drivers/xf86-input-evdev
+ x11-drivers/xf86-input-libinput
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep qqc2-desktop-style)
+ $(add_plasma_dep breeze)
+ $(add_plasma_dep kde-cli-tools)
+ $(add_plasma_dep oxygen)
+ $(add_qt_dep qtgraphicaleffects)
+ sys-apps/util-linux
+ x11-apps/setxkbmap
+ !kde-apps/kcontrol
+ !<kde-apps/kde4-l10n-17.08.1-r1
+ !kde-apps/knetattach[handbook]
+ !kde-misc/kcm-touchpad
+ !kde-plasma/plasma-desktop:4
+ !kde-plasma/plasma-workspace:4
+ !kde-plasma/solid-actions-kcm:4
+ !kde-plasma/systemsettings:4
+"
+
+PATCHES=( "${FILESDIR}/${P}-taskbar-crash.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package fontconfig Fontconfig)
+ $(cmake-utils_use_find_package ibus IBus)
+ $(cmake-utils_use_find_package mouse Evdev)
+ $(cmake-utils_use_find_package mouse XorgLibinput)
+ $(cmake-utils_use_find_package scim SCIM)
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package touchpad Synaptics)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # parallel tests fail, foldermodeltest,positionertest hang, bug #646890
+ # needs D-Bus, bug #634166
+ local myctestargs=(
+ -j1
+ -E "(foldermodeltest|positionertest|test_kio_fonts)"
+ )
+
+ kde5_src_test
+}