summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leogrande <dark.knight.ita@gmail.com>2021-03-27 18:21:25 -0700
committerSam James <sam@gentoo.org>2021-05-09 06:29:06 +0000
commit26f770afdc68a089f56006f107eb97a0cde7b02f (patch)
treef9e62391e27e9275344d7b5a4c7fb29195c38414
parentdev-python/py-gfm: bump to 1.0.2 (diff)
downloadgentoo-26f770afdc68a089f56006f107eb97a0cde7b02f.tar.gz
gentoo-26f770afdc68a089f56006f107eb97a0cde7b02f.tar.bz2
gentoo-26f770afdc68a089f56006f107eb97a0cde7b02f.zip
sys-fs/dislocker: bump to version 0.7.3
This version includes a fix to prevent dislocker from segfaulting when reading bitlocker-encrypted partitions created by recent versions of Windows 10: https://github.com/Aorimn/dislocker/issues/185 Closes: https://bugs.gentoo.org/766540 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Marco Leogrande <dark.knight.ita@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20157 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-fs/dislocker/Manifest1
-rw-r--r--sys-fs/dislocker/dislocker-0.7.3.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-fs/dislocker/Manifest b/sys-fs/dislocker/Manifest
index 40ff38a7b8fe..f50b11e8fd11 100644
--- a/sys-fs/dislocker/Manifest
+++ b/sys-fs/dislocker/Manifest
@@ -1,2 +1,3 @@
DIST dislocker-0.7.1-fix-find-ruby.patch 25942 BLAKE2B bd9d93c5eddcbade0039c1787dae36f5dd01f91cd435dfb9dbcfcb16f0f09cba7e73a3221c8b2f3843d0a68199fb9e38bdb91428fa784442659f7af53ab6d4dd SHA512 70f5a628659ef4645d757b899f3e6310e3a4d2ab89f429748c711177a0944e9b0eabf5341e394ab09216b0fa18e3c2b0832406b27f40c04510df937ffe5f65ef
DIST dislocker-0.7.1.tar.gz 103194 BLAKE2B 05421b0d3e7686480e40a41e67086017c454b76e0852fef78a7b5d10134cf388b4bf7b9669d87b867418f4c074cc023ea9b0260dbdbc837322d04f217aa40b28 SHA512 8852ba3e363fdea992eebecfe1e4dad2b85404f57c57ce6b2937a9859d03cfa88d969926c9e11e6d22596c6d96805b7d1737893ae2c5a957448ab26708bce226
+DIST dislocker-0.7.3.tar.gz 111257 BLAKE2B ba8403facfef04f5194a22421d2010d472b073d6dce03c9f457d7661de11bb818782cc66bfee8cd88fe72af7ac127bbbcbe1a01c5c35f0cf054f282b3208c3ea SHA512 c62241d70d51f6445a2f6d0f08e099bbc1a4257ca98232471fc43ec63e69d62ae5f702c995ec00b7e1db7d33f4bb3a31ea05bc13862bf3b539feb301a0e034ff
diff --git a/sys-fs/dislocker/dislocker-0.7.3.ebuild b/sys-fs/dislocker/dislocker-0.7.3.ebuild
new file mode 100644
index 000000000000..f568ccf9b768
--- /dev/null
+++ b/sys-fs/dislocker/dislocker-0.7.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Dislocker is used to read BitLocker encrypted partitions."
+HOMEPAGE="https://github.com/Aorimn/dislocker"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Aorimn/dislocker.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Aorimn/dislocker/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~juippis/distfiles/tmp/dislocker-0.7.1-fix-find-ruby.patch"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ruby"
+
+DEPEND="
+ sys-fs/fuse:0=
+ net-libs/mbedtls:0=
+ ruby? ( dev-lang/ruby:* )
+"
+RDEPEND="${DEPEND}"
+
+CMAKE_REMOVE_MODULES_LIST="${CMAKE_REMOVE_MODULES_LIST} FindRuby"
+
+src_prepare() {
+ if use ruby && [[ ${PV} == "0.7.1" ]]; then
+ PATCHES=( "${DISTDIR}/${P}-fix-find-ruby.patch" )
+ fi
+ cmake_src_prepare
+
+# We either need to change Werror to Wno-error or remove the multiple declarations of FORTIFY_SOURCE
+# sed 's:Werror:Wno-error:g' -i "${S}/src/CMakeLists.txt" || die
+ sed 's:-D_FORTIFY_SOURCE=2::g' -i "${S}/src/CMakeLists.txt" || die
+
+# sed 's:\.\./man:'../../${P}/man':g' -i "${S}/src/CMakeLists.txt" || die
+# Do not process compressed versions of the manuals
+ sed -r 's:( create_symlink \$\{BIN_FUSE\}\.1)\.gz (.+\.1)\.gz\\:\1 \2\\:' -i "${S}/src/CMakeLists.txt" || die
+ sed -r 's:^(.+\.1\.gz):#\1:' -i "${S}/src/CMakeLists.txt" || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake_use_find_package ruby Ruby)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ if ! use ruby; then
+ rm "${S}/man/linux/${PN}-find.1" || die
+ fi
+ find "${S}/man/linux" -name '*.1' -exec doman '{}' +
+ cmake_src_install
+}