summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-19 09:58:21 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-19 15:01:23 +0200
commit26fa7c9802aa114d00973acbde08bfc910df2a74 (patch)
tree6ca7a9c37c1eaee0f33d31a8cb7c1e07849b3dd2
parentdev-ada/gnatsymbolize: drop <gnat_2019 support (diff)
downloadgentoo-26fa7c98.tar.gz
gentoo-26fa7c98.tar.bz2
gentoo-26fa7c98.zip
dev-python/aesara: Bump to 2.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/aesara/Manifest1
-rw-r--r--dev-python/aesara/aesara-2.2.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index 2b77f643a0ea..475bea254ebc 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1,2 +1,3 @@
DIST aesara-rel-2.1.3.tar.gz 8170822 BLAKE2B dbbc4a453c5d7f9cd4ab2c925dd9293e835db23100686a8d7ab2c47182b1bc05f883eeb60d6f47f8f34e4187f3ac07b632cde43fe82a99e2145a2f699a2b3582 SHA512 52d1724eb7b3c9bae4bdbf1735db9ef96cdfa94f3e2281b255201d0baba260fe31f78c00719a53ce3c59ea9c66ff218d8acd7bc012b386942f29806c07ffc466
DIST aesara-rel-2.2.1.tar.gz 8166022 BLAKE2B af3c17029dacb3d365bf49eb01d4d03b5a4f770f66d3e5eba2c4576ef156056bc1aca3571442c1cb7352c358978b47faa7af70ca0da2a2168d8c9bfd47b17138 SHA512 f7bab8ca80e8d13ef7698c1efa56ff37c561786330bf756c7a00c54ae1f131810d68bfd6e328b0705d45788759bd984d42306d2c545d2de6b9a3592b5c021ad8
+DIST aesara-rel-2.2.2.tar.gz 8174667 BLAKE2B e0b22e7e38dbff1089b0db77ee55fbc8f1847da576a54b1f59a34c22d9bb777f108b8d06d3e4cddeb826f4bee566d32f6b4ec013f96ee61ecce6924188aa1dc7 SHA512 1f2eff0c959605a09521d15010058851e8dc340ca84d760baf6166508e37cc7734e8737ca199618f4e9bd33bd04c053add0a790917f4c125052631f693383945
diff --git a/dev-python/aesara/aesara-2.2.2.ebuild b/dev-python/aesara/aesara-2.2.2.ebuild
new file mode 100644
index 000000000000..3148f85f3cf9
--- /dev/null
+++ b/dev-python/aesara/aesara-2.2.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+MY_P=aesara-rel-${PV}
+DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
+HOMEPAGE="https://github.com/aesara-devs/aesara"
+SRC_URI="https://github.com/aesara-devs/aesara/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.17.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc 'dev-python/sphinx_rtd_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e "s/tests.\*/tests\*/" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local exclude=(
+ # speed tests are unreliable
+ tests/scan/test_basic.py::test_speed
+ tests/scan/test_basic.py::test_speed_rnn
+ tests/scan/test_basic.py::test_speed_batchrnn
+ tests/link/test_vm.py::test_speed
+ tests/link/test_vm.py::test_speed_lazy
+ tests/tensor/test_gc.py::test_merge_opt_runtime
+
+ # rounding problem?
+ # https://github.com/aesara-devs/aesara/issues/477
+ tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
+ tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
+ )
+
+ distutils_install_for_testing
+ # we do not package numba
+ epytest ${exclude[@]/#/--deselect } \
+ --ignore tests/link/test_numba.py \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+# https://dev.gentoo.org/~mgorny/python-guide/concept.html#packaging-pkgutil-style-namespaces-in-gentoo
+python_install() {
+ rm "${BUILD_DIR}"/lib/bin/__init__.py || die
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
+ optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
+}