summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcharIes17 <charles17@arcor.de>2017-07-27 19:09:30 +0200
committerDavid Seifert <soap@gentoo.org>2017-07-30 17:13:13 +0200
commit27197097a91a887a8ba3b9a3a0515e9eeea72836 (patch)
tree00be20ace02381737d794ac0d14fb8fdeb778a24
parentx11-misc/pcmanfm: Add patch for CVE-2017-8934 (diff)
downloadgentoo-27197097.tar.gz
gentoo-27197097.tar.bz2
gentoo-27197097.zip
x11-misc/pcmanfm: Bump live ebuild to EAPI 6
* Remove unused pcmanfm-1.2.4-fix-no-common.patch * Adjust eclass to readme.gentoo-r1 * Adjust SRC_URI same as in 1.2.5 * Remove old lines for Bug #382265, #382265, #421101 Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5118
-rw-r--r--x11-misc/pcmanfm/files/pcmanfm-1.2.4-fix-no-common.patch11
-rw-r--r--x11-misc/pcmanfm/pcmanfm-9999.ebuild34
2 files changed, 19 insertions, 26 deletions
diff --git a/x11-misc/pcmanfm/files/pcmanfm-1.2.4-fix-no-common.patch b/x11-misc/pcmanfm/files/pcmanfm-1.2.4-fix-no-common.patch
deleted file mode 100644
index 46b0ac876f95..000000000000
--- a/x11-misc/pcmanfm/files/pcmanfm-1.2.4-fix-no-common.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/tab-page.h 2014-08-24 00:46:28.000000000 +0200
-+++ b/src/tab-page.h 2016-08-21 18:12:33.509482924 +0200
-@@ -147,7 +147,7 @@
- #if FM_CHECK_VERSION(1, 2, 0)
- #include "pcmanfm-modules.h"
-
--GList *_tab_page_modules; /* in pcmanfm.c */
-+extern GList *_tab_page_modules; /* in pcmanfm.c */
- #endif
-
- G_END_DECLS
diff --git a/x11-misc/pcmanfm/pcmanfm-9999.ebuild b/x11-misc/pcmanfm/pcmanfm-9999.ebuild
index 5edc83ba4c05..d721dbfcaf5b 100644
--- a/x11-misc/pcmanfm/pcmanfm-9999.ebuild
+++ b/x11-misc/pcmanfm/pcmanfm-9999.ebuild
@@ -1,20 +1,21 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
+
PLOCALES="ar be bg bn ca cs da de el en_GB es et eu fa fi fo fr gl he hr hu id
is it ja kk km ko lg lt lv ms nl pa pl pt pt_BR ro ru si sk sl sr sr@latin sv
te th tr tt_RU ug uk vi zh_CN zh_TW"
PLOCALE_BACKUP="en_GB"
-inherit autotools eutils fdo-mime l10n readme.gentoo
+inherit autotools eutils fdo-mime l10n readme.gentoo-r1
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}"
inherit git-r3
KEYWORDS=""
else
- SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${MY_P}.tar.xz"
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~x86"
fi
@@ -43,25 +44,28 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/${MY_P}
-DOCS=( AUTHORS )
-
-DOC_CONTENTS="PCmanFM can optionally support the menu://applications/
- location. You should install lxde-base/lxmenu-data for that functionality."
-
src_prepare() {
+ default
+
intltoolize --force --copy --automake || die
- # drop -O0 -g. Bug #382265 and #382265
- sed -i -e "s:-O0::" -e "/-DG_ENABLE_DEBUG/s: -g::" "${S}"/configure.ac || die
- #Remove -Werror for automake-1.12. Bug #421101
- sed -i "s:-Werror::" configure.ac || die
eautoreconf
+
export LINGUAS="${LINGUAS:-${PLOCALE_BACKUP}}"
- l10n_get_locales > "${S}"/po/LINGUAS
- epatch_user
+ l10n_get_locales > po/LINGUAS || die
}
src_configure() {
- econf --sysconfdir="${EPREFIX}/etc" $(use_enable debug)
+ econf \
+ --sysconfdir="${EPREFIX}"/etc \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ local DOC_CONTENTS="PCmanFM can optionally support the menu://applications/
+ location. You should install lxde-base/lxmenu-data for that functionality."
+ readme.gentoo_create_doc
}
pkg_postinst() {