summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-11-20 08:16:53 +0100
committerMikle Kolyada <zlogene@gentoo.org>2018-11-21 18:18:14 +0300
commit271e6c41320606e81b9831660eb8fe65a90ed877 (patch)
treed7ca8f6fa5d58ff349fb517be47a2338212cb9f6
parentsci-libs/linux-gpib: Version bump (diff)
downloadgentoo-271e6c41.tar.gz
gentoo-271e6c41.tar.bz2
gentoo-271e6c41.zip
dev-python/humanfriendly: bump to 4.17
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10452 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--dev-python/humanfriendly/Manifest1
-rw-r--r--dev-python/humanfriendly/humanfriendly-4.17.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/Manifest b/dev-python/humanfriendly/Manifest
index cedb22b5d029..f089ba785725 100644
--- a/dev-python/humanfriendly/Manifest
+++ b/dev-python/humanfriendly/Manifest
@@ -1 +1,2 @@
DIST humanfriendly-2.4.tar.gz 51037 BLAKE2B 3775505a8a32c19b921d6f397951dc61da9d5c4d3c8313a519cb350d4dcee09797b4d3412c7084d6a722397e675be345af946e132058e57d77e426d3ca2a3230 SHA512 e35017c6be9d80ac5e3465836aae4f5b1ea4358224e250c7c1b7e3a93c2764832382e0ec24ea54e1d656fd8874c12b23ffc535440870b55a532800c5953cc676
+DIST humanfriendly-4.17.tar.gz 344455 BLAKE2B 985ae142ea5378fcceb9f5f28773ac4dcaf0ea55ef1a7269fd1840a0b7119b54362aa93c330aa62e5424cc6f329e88717b45255c62b8e1d3f9ff5dd43a3c16c2 SHA512 a5786f28eaa0ff33919d9164ff30037fef5dbf60a31aece7679d1dddf3239f5a0d27209c710053cb0ac6779c1ef39102b1441fc620063283e90ef2ae11f8b621
diff --git a/dev-python/humanfriendly/humanfriendly-4.17.ebuild b/dev-python/humanfriendly/humanfriendly-4.17.ebuild
new file mode 100644
index 000000000000..bb442e83cbbb
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-4.17.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_PN="python-${PN}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.org/project/humanfriendly/ https://humanfriendly.readthedocs.org"
+SRC_URI="https://github.com/xolox/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/monotonic[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/capturer-2.1[${PYTHON_USEDEP}]
+ >=dev-python/coloredlogs-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4.0[${PYTHON_USEDEP}]
+ )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ pytest -v || die
+}