summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2021-01-25 19:50:57 -0700
committerTim Harder <radhermit@gentoo.org>2021-01-25 20:07:47 -0700
commit27384a43f8f5c57ceceacdc0259e5e4df0d7a292 (patch)
tree4797ce2e52d08ea8729ff268ed49069639b88ec9
parentdev-lang/spidermonkey: bump to v78.7.0 (diff)
downloadgentoo-27384a43.tar.gz
gentoo-27384a43.tar.bz2
gentoo-27384a43.zip
dev-python/pychroot: version bump to 0.10.4
Closes: https://bugs.gentoo.org/767205 Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--dev-python/pychroot/Manifest1
-rw-r--r--dev-python/pychroot/pychroot-0.10.4.ebuild44
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild2
3 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/pychroot/Manifest b/dev-python/pychroot/Manifest
index 374595c93e08..bda37e820735 100644
--- a/dev-python/pychroot/Manifest
+++ b/dev-python/pychroot/Manifest
@@ -1 +1,2 @@
DIST pychroot-0.10.3.tar.gz 23637 BLAKE2B 9ea0d3fdbabddd2901cf263b9f29eb91a6a6eb732c8973773c69630a320d6e39f458fb4f420f099617ba4f6e43353fe36dc4576cb84bca271a8e7b4db260b36c SHA512 b4d9fab3d2ba9bd5fd9bf6bcb988a1e63ea03aef0c898baf724d51de97943cb41c0223a235f4fa9f733cf737a3089a90006ae5ecb9049d74ec8c78712a1b6e7a
+DIST pychroot-0.10.4.tar.gz 23745 BLAKE2B cce7be8c88b193b69838f14dfad62a5374936039bfe6478b8448b9a7f9e1ffcb373d5649ad1953beec6ca9ae138adc6871e129418a6fc64067b09eb6d4b4fa4c SHA512 fd93dba0a104eebe238f56e254fc445e1d34a2dbec6dcc307327fb92ebd7c85b1e729497ec818b756dee934f267cad755037ff004f78623d858617e39b473468
diff --git a/dev-python/pychroot/pychroot-0.10.4.ebuild b/dev-python/pychroot/pychroot-0.10.4.ebuild
new file mode 100644
index 000000000000..6258c1a766d0
--- /dev/null
+++ b/dev-python/pychroot/pychroot-0.10.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a python library and cli tool that simplify chroot handling"
+HOMEPAGE="https://github.com/pkgcore/pychroot"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND=">=dev-python/snakeoil-0.8.9[${PYTHON_USEDEP}]"
+fi
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst README.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index 9ec7b332eb8a..6258c1a766d0 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7